Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

No input file specified / godaddy
 
centtaco
Member
 
Total Posts:  55
Joined:  2009-05-12
 

Ok so at first I was getting the “no input file specified” when I would go to http://www.mypage.com/magento/install
I did the godaddy fix’s to the htacess file and the php5.ini file..

so now it gets to the Welcome install page. I click next and I get the same “ No input file specified”

it trys to go to index.php/install/wizard/beginPost/

What am I doing wrong?

i used the FTP program with godaddy.com / changed the premissions to 777 in the file manager

Please somebody help

 
Magento Community Magento Community
Magento Community
Magento Community
 
lamesnake
Jr. Member
 
Total Posts:  1
Joined:  2011-04-04
 

rename php.ini file to php5.ini. if there is no php.ini file in the root directory please copy php.ini.sample file from your magento directory to root directory as php5.ini

Good Luck

 
Magento Community Magento Community
Magento Community
Magento Community
 
LauraB
Jr. Member
 
Total Posts:  3
Joined:  2011-02-23
 

If you are still having the problem of “no file input specified” after changing the htaccess and php5.ini files as posted everywhere in this forum… and are using GoDaddy, try this:

Login to your Godaddy Account.  Click on your hosting account. 
Go to Settings > File Extensions Management

and change .php and .php5 to run under PHP5.2X (instead of PHP5.2xFastCGI)

I had tried everything posted in the forums and kept getting the “no input file selected” even after getting to the installation page and clicking continue.....for an entire week and the above fix is what finally worked for me!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ashishkhadpe
Member
 
Total Posts:  58
Joined:  2011-08-22
 

This problem generally occurs with GoDaddy web hosting
This Problem can be solved by following Guidelines provided at
Blog Link : Magento coders

 
Magento Community Magento Community
Magento Community
Magento Community
 
efren181
Jr. Member
 
Total Posts:  1
Joined:  2011-09-27
 

i have magento installed in a deluxe hosting plan in its own directory.

by root is the php5.ini file supposed to be in the web root or directory it is installed in?

(*godaddyAbsoluteHostingPath*/html)/php5.ini

OR

(*godaddyAbsoluteHostingPath*/html)/magento/php5.ini ?

thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
MageFam
Member
 
Avatar
Total Posts:  71
Joined:  2010-11-27
Minneapolis, USA
 

A common error, which usually comes up if you’re hosted by GoDaddy, is the no input file specified error.

If you do not have Magento setup in the root of your server, make sure to add the following to your .htaccess file.

RewriteBase /yourbasepath/

In your web root directory, there should be a file called php.ini. Rename this to php5.ini.

If there is no php5.ini file. Create the file and upload it to your root directory.

If that doesn’t work, add the following to the end of your newly renamed php5.ini file:

cgi.fix_pathinfo 1

And if you’re still getting the error, add the following to the top of your .htaccess file:

Options -MultiViews

If nothing above worked, call GoDaddy up and have them either rename this for you, or make sure you’re on PHP 5.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jeffburow
Jr. Member
 
Total Posts:  1
Joined:  2012-08-08
 
LauraB - 24 October 2011 10:39 AM

If you are still having the problem of “no file input specified” after changing the htaccess and php5.ini files as posted everywhere in this forum… and are using GoDaddy, try this:

Login to your Godaddy Account.  Click on your hosting account. 
Go to Settings > File Extensions Management

and change .php and .php5 to run under PHP5.2X (instead of PHP5.2xFastCGI)

I had tried everything posted in the forums and kept getting the “no input file selected” even after getting to the installation page and clicking continue.....for an entire week and the above fix is what finally worked for me!!!!

YOU ARE AWESOME!!

I tried EVERYTHING, and was pulling my hair out. This fixed it!

 
Magento Community Magento Community
Magento Community
Magento Community
 
zen0917
Jr. Member
 
Total Posts:  1
Joined:  2012-08-12
 
LauraB - 24 October 2011 10:39 AM

If you are still having the problem of “no file input specified” after changing the htaccess and php5.ini files as posted everywhere in this forum… and are using GoDaddy, try this:

Login to your Godaddy Account.  Click on your hosting account. 
Go to Settings > File Extensions Management

and change .php and .php5 to run under PHP5.2X (instead of PHP5.2xFastCGI)

I had tried everything posted in the forums and kept getting the “no input file selected” even after getting to the installation page and clicking continue.....for an entire week and the above fix is what finally worked for me!!!!

Great! Thanks!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
rahulajani
Jr. Member
 
Total Posts:  1
Joined:  2012-12-23
 
LauraB - 24 October 2011 10:39 AM

If you are still having the problem of “no file input specified” after changing the htaccess and php5.ini files as posted everywhere in this forum… and are using GoDaddy, try this:

Login to your Godaddy Account.  Click on your hosting account. 
Go to Settings > File Extensions Management

and change .php and .php5 to run under PHP5.2X (instead of PHP5.2xFastCGI)

I had tried everything posted in the forums and kept getting the “no input file selected” even after getting to the installation page and clicking continue.....for an entire week and the above fix is what finally worked for me!!!!

Wow! This worked! I tried everything suggested to edit .php5 and .htaccess file. And I was still getting error in installing Magento on GoDaddy. The moment I tried this solution, it worked! Thanks a lot dear!

 
Magento Community Magento Community
Magento Community
Magento Community
 
viswaram
Jr. Member
 
Total Posts:  1
Joined:  2013-04-06
 

This is exactly the solution i was looking for.. great work

// File Extensions Management - change the .php to run under PHP 5.2.x grin

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top