Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Modern Theme in Magento 1.1 Recovery
 
Inspire Commerce
Jr. Member
 
Total Posts:  12
Joined:  2008-07-13
 

I installed Modern Theme and ran into a couple bugs.  I then removed the theme, cleared the cache, and am not getting the following message on product pages.  Please help!  “How Do I” fix this?

Invalid method Mage_Core_Block_Template_Facade::insertBlockIfEquals(Array
(
[0] => product.info.options
[1] => alias_in_layout
[2] => options_container
)
)

#0 [internal function]: Varien_Object->__call(’insertBlockIfEq...’, Array)
#1 /home/ergobaby/public_html/app/code/core/Mage/Core/Model/Layout.php(322): Mage_Core_Block_Template_Facade->insertBlockIfEquals(’product.info.op...’, ‘alias_in_layout’, ‘options_contain...’)
#2 /home/ergobaby/public_html/app/code/core/Mage/Core/Model/Layout.php(198): Mage_Core_Model_Layout->_generateAction(Array, Array)
#3 /home/ergobaby/public_html/app/code/core/Mage/Core/Model/Layout.php(190): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element), Object(Mage_Core_Model_Layout_Element))
#4 /home/ergobaby/public_html/app/code/core/Mage/Core/Model/Layout.php(190): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#5 /home/ergobaby/public_html/app/code/core/Mage/Core/Model/Layout.php(194): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#6 /home/ergobaby/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(279): Mage_Core_Model_Layout->generateBlocks(Object(Mage_Core_Model_Layout_Element))
#7 /home/ergobaby/public_html/app/code/core/Mage/Catalog/controllers/ProductController.php(95): Mage_Core_Controller_Varien_Action->generateLayoutBlocks()
#8 /home/ergobaby/public_html/app/code/core/Mage/Catalog/controllers/ProductController.php(119): Mage_Catalog_ProductController->_initProductLayout()
#9 /home/ergobaby/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(343): Mage_Catalog_ProductController->viewAction(Object(Mage_Catalog_Model_Product))
#10 /home/ergobaby/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(144): Mage_Core_Controller_Varien_Action->dispatch()
#11 /home/ergobaby/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(168): Mage_Core_Controller_Varien_Router_Standard->match(’view’)
#12 /home/ergobaby/public_html/app/Mage.php(420): Mage_Core_Controller_Varien_Front->dispatch(Object(Mage_Core_Controller_Request_Http))
#13 /home/ergobaby/public_html/index.php(46): Mage::run()
#14 {main}

 
Magento Community Magento Community
Magento Community
Magento Community
 
BoostMyShop
Sr. Member
 
Avatar
Total Posts:  155
Joined:  2008-06-11
France
 

hi

this is due to a layout (xml file)
i had the same pb on catalog.xml, declaration have change.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top