Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 3
Invalid POST DATA
 
anStream
Jr. Member
 
Total Posts:  1
Joined:  2009-03-24
 

An action of the form in the Connection Manager (where you entering extension key) “pear_registry=1” part of query string is missed. Then after you submit the form if “pear_registry=1” is missed - process script redirects with adding “pear_registry” through GET method, and our POST data (extension key that we entered in the form) is lost. That’s why we give error “INVALID POST DATA”, because when processing - we have no POST data.

 
Magento Community Magento Community
Magento Community
Magento Community
 
captainEmn
Jr. Member
 
Total Posts:  25
Joined:  2009-02-16
 
anStream - 24 March 2009 06:44 AM

An action of the form in the Connection Manager (where you entering extension key) “pear_registry=1” part of query string is missed. Then after you submit the form if “pear_registry=1” is missed - process script redirects with adding “pear_registry” through GET method, and our POST data (extension key that we entered in the form) is lost. That’s why we give error “INVALID POST DATA”, because when processing - we have no POST data.

So what’s the solution ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
smart1234
Jr. Member
 
Total Posts:  15
Joined:  2009-02-23
 

Even after turning off my firewall on Local Server I get INVALID POST DATA ERROR after pressing install button in Magento connect manager.
Can anyone help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
supranoob
Jr. Member
 
Total Posts:  14
Joined:  2009-04-25
 

Great answers :|
Buuut, as you can see people are still having issues.
I for one am currently running ubuntu and have disabled the firewall completely.
Has anyone found a solution for this or anything else to try?

 
Magento Community Magento Community
Magento Community
Magento Community
 
michael_in_pp
Jr. Member
 
Total Posts:  11
Joined:  2008-05-27
 

I the same INVALID POST DATA ERROR message, and then some additional issues completing the installation of the extension I wanted.  The details here www.magentocommerce.com/boards/viewthread/46698/ gave me the solution

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tribsel
Jr. Member
 
Total Posts:  26
Joined:  2009-06-03
 

I had this problem too.  Invalid post data (in download manager) + I was not able to change preffered state (from beta to stable) + NO ACTION SELECTED error in case I wanted to upgrade some extensions.

I resolved this by reverting to default .htaccess file, so check your .htaccess file

 
Magento Community Magento Community
Magento Community
Magento Community
 
stefacht
Jr. Member
 
Total Posts:  16
Joined:  2009-11-16
 

I had the same problem and it was definitely a firewall problem!
Now that I’ve allowed the webserver can access any ips on port 80 and 443 without proxy, everything works fine!

stef

 
Magento Community Magento Community
Magento Community
Magento Community
 
arjinto
Jr. Member
 
Total Posts:  1
Joined:  2009-10-20
 

if you changed directory downloader to chmod 777, and you got error “INAVALID POST DATA”. you need to change directory chmod 777
1. app/design/adminhtml/default/default/layout
2./app/design/frontend/default/default/locale
3. /app/code/local

when you instal extension uncheck “Auto-scroll console contents”
try this. i fix it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Angelobhl
Jr. Member
 
Total Posts:  2
Joined:  2009-12-28
 

I changed all directory to chmod 777
Then I find an error message in /magento/downloader/pearlib/php/PEAR/REST.php on line 344 or 353

$fp = @fsockopen($proxy_host$proxy_port$errno$errstr15);
or
$fp = @fsockopen($host$port$errno$errstr);
echo $errstr, I see the message:\"php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution in ...\”
then I googled it, and I am asked to restart the apache
Stop apache, then start apache, so it works, I can download in magento connect
But each time when I restarted the fedora system, I have to restart apache if I want to download.
 
Magento Community Magento Community
Magento Community
Magento Community
 
dvanzan
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2010-06-29
 
Tribsel - 08 November 2009 08:13 AM

I had this problem too.  Invalid post data (in download manager) + I was not able to change preffered state (from beta to stable) + NO ACTION SELECTED error in case I wanted to upgrade some extensions.

I resolved this by reverting to default .htaccess file, so check your .htaccess file

Hi
I had the same problem on my site and I after trying a lot of things linke resetting permissions (everything was working before it suddenly messed up so I was sceptic about a permission problem as I dont see how on a linux server permissions could have been bypassed). I also tried editting Pear.php file, editting pear.ini file but in vain.
I finally figured out were was the problem. The solution was right in front of my eyes but I did not want to believe or even try it as I was very certain I was right about it : The .htaccess file.
I solved it by removing the .htaccess file and starting over with the sample .htaccess file provided and surprise, everything worked.
Now, I will try to figure out which line was causing problem. I think it has something to do with Rewritebase and Rewriterules.
And I am pretty sure I was dumb enough to put Rewritebase /subfolder/ on an .htaccess file stored in a one level below folder.
Sorry for the bad english, it’s not my language
Hope it will help
bye

 
Magento Community Magento Community
Magento Community
Magento Community
 
dvanzan
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2010-06-29
 

I found out that the modification that permit to redirect through www.yoursite.com in htaccess was screwing the downloader.

RewriteCond %{THE_REQUEST} ^.*/index.php
RewriteRule 
^(.*)index.phphttp://www.domain.com/shop/$1 [R=301,L]

RewriteCond %{THE_REQUEST} ^.*/index.php/
RewriteRule ^(.*)index.php/$ http://www.domain.com/shop/$1 [R=301,L]

RewriteCond %{http_host} ^domain.com [NC]
RewriteRule 
^(.*)$ http://www.domain.com/shop/$1 [R=301,NC]
With this code everything is okay except thedownloader

Do someone know how I can implement the automatic redirection to http://www.domain.com if my customers try to enter the site through http://domain.com ?
headaches!

 
Magento Community Magento Community
Magento Community
Magento Community
 
meia
Jr. Member
 
Total Posts:  19
Joined:  2010-06-14
 

I had this issue and with the help of our service providers we manage to fix it so here is the solution we used. This is very technical for me..
====START====

Problem: Error “INVALID POST DATA” when installing Extensions via Magento Connect

Solution:

This seemingly-vague error message is rather straight-forward to solve. While I don’t claim to be an expert on Magento, these are the things I did to resolve this problem.

First, make sure that your firewall settings are correct - your site will need to be able to access connect.magentocommerce.com. Ask your host to check to see if it isn’t blocked by accident and that they can ping/traceroute/telnet to it from the server or network (in rare cases there may be networking issues between your host and the Magento’s servers)

Secondly, make sure that permissions are set correctly on the files. This will depend on your hosting setup, but normally the FTP user and the webserver user are different and both will need to have read/write access to the files and folders. I’ve seen recommendations for a permissions level of 664, however I’ve encountered issues with Apache not being able to read folders correctly without the executable bit set, thus 774/775 should be sufficient for everyone. If you’re not sure then please ask your hosting company.

Now, you should stop receiving that error. However, if you retried the download and it gave an error about unknown channels or that the connection to ‘proxy:3128’ failed, then it looks like pear is a bit broken.

This is solved the quickest via SSH. To fix the ‘unknown channels’ error, go into the root magento directory and run the following command:

./pear list-channels

If it can’t find the file, make sure that a) it exists b) it’s set to be executable for your user (if you aren’t sure, make its permissions 777, but note that this is rather insecure)

If the file exists and your user is allowed to run it, you should see a list of channels, eg:

doc.php.net
pear.php.net
pecl.php.net
__uri

Should you not see anything about Magento there, re-configure pear using the following command:

./pear mage-setup

You should see output like the following:

Running initial setup…
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
config-set succeeded
Adding Channel “connect.magentocommerce.com/core” succeeded
Discovery of channel “connect.magentocommerce.com/core” succeeded
Adding Channel “connect.magentocommerce.com/community” succeeded
Discovery of channel “connect.magentocommerce.com/community” succeeded

If you run “./pear list-channels” again you should see a list like the following:

connect.magentocommerce.com/community
connect.magentocommerce.com/core
doc.php.net phpdocs
pear.php.net
pecl.php.net
__uri

To fix the issue with connecting to ‘proxy:3128’, edit the file downloader/Maged/Pear.php and comment out the following line:

$config->set(’http_proxy’, ‘http://proxy:3128/’)

The ‘http_proxy’ setting is used in the rare case where your site is behind a firewall, or when it needs to talk to an upstream proxy server or similar. In the majority of cases, this setting is not needed, however if you’re not sure ask your host or server administrator.

The download should work now.
Thank you to xtrahost our service provider for the answer>
http://www.xtrahost.co.uk/magento/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fuzzical Logic
Jr. Member
 
Total Posts:  1
Joined:  2010-12-02
 

After experiencing my own problems with this error, I found that turning off URL Rewrites by .htaccess and addon fixed the issue. Apparently the Magento PEAR module does not detect rewrites correctly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sachu777
Jr. Member
 
Total Posts:  2
Joined:  2010-10-31
 

I tried a lot of threads it finally this trick worked for me.

1. I logged in to magento connect in admin.
2. Deleted the .htaccess at the root of the site and put the Extension Key and was able to install successfully.
3. Uploaded the .htaccess again.

It means there was some rule in .htaccess file that was blocking magento connect to install Extensions
and generating INVALID POST DATA error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
surfpacific
Jr. Member
 
Total Posts:  11
Joined:  2011-03-20
 
sachu777 - 04 February 2011 03:41 AM

I tried a lot of threads it finally this trick worked for me.

1. I logged in to magento connect in admin.
2. Deleted the .htaccess at the root of the site and put the Extension Key and was able to install successfully.
3. Uploaded the .htaccess again.

It means there was some rule in .htaccess file that was blocking magento connect to install Extensions
and generating INVALID POST DATA error.

Thanks so much! This worked for me as well.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 3