Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
Invalid POST DATA
 
lakikeanu
Jr. Member
 
Total Posts:  24
Joined:  2008-06-16
 

when go try to download an extenction in magento connect ....
it always says INVALID POST DATA…

WHY ?

i set the write permission to downloader directory.

i’m using XAMPP 1.6.7 and magento 1.1.1 stable

 
Magento Community Magento Community
Magento Community
Magento Community
 
smlaci
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2008-04-15
Bacau
 

i have the same problem.
it is a bit strange though.
2 websites on 2 servers at the same hosting provider, they say that settings are the same.
on one the downloader works, on one it doesn’t.
i’ve tried with 1.1.1 and the previous version also.
if i use the downloader to install i get PEAR error unknown command ‘install’
if i use the full release, it installs ok, but the connect manager give me the invalid post data error when i try to install any extension.

 
Magento Community Magento Community
Magento Community
Magento Community
 
browserweb
Jr. Member
 
Total Posts:  4
Joined:  2008-02-17
Houston, TX USA
 

I have the same problem.
After setting SSH permissions to get the downloader working I input the key into the downloader and get the same error message INVALID POST DATA

 
Magento Community Magento Community
Magento Community
Magento Community
 
smlaci
Sr. Member
 
Avatar
Total Posts:  122
Joined:  2008-04-15
Bacau
 

i have talked to the tech support for my server and they said that there might be a problem with the PEAR on the server, they will try to repair or reinstall PEAR and after that the downloader should work perfect. will wait and see.

 
Magento Community Magento Community
Magento Community
Magento Community
 
browserweb
Jr. Member
 
Total Posts:  4
Joined:  2008-02-17
Houston, TX USA
 

PEAR is fine on my server but I finally managed to find the answer on the wiki…

http://www.magentocommerce.com/wiki/upgrading_magento#upgrading_magento_using_the_magentoconnect_manager

Worked for me, best of luck everyone, hope that helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
creative_dave
Jr. Member
 
Total Posts:  11
Joined:  2008-09-22
 

I’m having this problem too, even when trying the suggested solution.

I’m using Magento 1.1.4 - it’s all installed properly and working. I just can’t get the Download / Connect part to work?!?

Can anybody suggest any alternative fixes?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
creative_dave
Jr. Member
 
Total Posts:  11
Joined:  2008-09-22
 

Please!, has anybody successfulyl resolved this problem? I’ve set all permissions to 777 on the entire downloads folder, even all of the files too and i’m still getting this error!??!

 
Magento Community Magento Community
Magento Community
Magento Community
 
creative_dave
Jr. Member
 
Total Posts:  11
Joined:  2008-09-22
 

Fixed it!! The server filewall settings were too strict, that was my problem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Juan R
Jr. Member
 
Total Posts:  9
Joined:  2008-09-26
 
creative_dave - 24 September 2008 06:12 AM

Fixed it!! The server filewall settings were too strict, that was my problem.

Umm firewall??
I’ve an magento store under windows xp sp3 and no problem with magento connect.
The same store with the same configuration in apache / php /pear under Windows Vista and… “INVALID POST DATA”

 
Magento Community Magento Community
Magento Community
Magento Community
 
Juan R
Jr. Member
 
Total Posts:  9
Joined:  2008-09-26
 

Glups, in windows vista execute internet explorer like admin wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
mitchwoods
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2008-09-27
Auckland, New Zealand
 

Dave has the right answer.

Servers operate behind a firewall so if the software is attempting to connect out to retrieve modules or extensions then it is likely that they will need to allow an exception to allow the outgoing connection.

Your host will need the IP address of the software source.

 
Magento Community Magento Community
Magento Community
Magento Community
 
piotrekkaminski
Magento Team
 
Avatar
Total Posts:  73
Joined:  2007-09-01
 

Hello

You should add exception to allow connection to connect.magentocommerce.com. Remember similar situation happens if you are using some of the payment modules like Authorize.net - you will have to add exception to allow the module to connect to authorize.net server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Petroski
Jr. Member
 
Total Posts:  17
Joined:  2008-03-31
 

I have the same error....

and I disabled the firewall of my server, but the error still there.

I have another installation with a previous version of magento on the same server and the connect dont say “invalid post data”, but doesn’t work.

I’m using plesk on linux.

It’s the worstest error that nobody knows how fix it????

Excuse my english

Admins of magento world show us the light!!!!

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Danroy
Jr. Member
 
Total Posts:  5
Joined:  2007-11-19
 

I too was stuck with this problem until I acted on the suggestion below.

piotrekkaminski - 07 October 2008 02:09 AM

Hello

You should add exception to allow connection to connect.magentocommerce.com. Remember similar situation happens if you are using some of the payment modules like Authorize.net - you will have to add exception to allow the module to connect to authorize.net server.

My host added “connect.magentocommerce.com” as an exception through their firewall and it all work sweet as.

Hope this helps someone else.

Thanks,
Dan

 
Magento Community Magento Community
Magento Community
Magento Community
 
pixelhorse
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2008-06-12
Germany
 

My solution was:

Editing the memory limit in .htaccess file in magento root folder to the value of 256M - see example below.

############################################
## adjust memory limit

#    php_value memory_limit 64M
    php_value memory_limit 128M
    php_value max_execution_time 18000
 
Magento Community Magento Community
Magento Community
Magento Community
 
chex
Jr. Member
 
Total Posts:  2
Joined:  2008-11-06
 

As for adding an exception...my host wants to know what port needs to be open as part of that exception....Any ideas what I should tell them? or does it even matter?

Thanks…

cd

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3