Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Google Sitemap in Magento 1.1 Stable Broken? 
 
aarondrabeck
Jr. Member
 
Total Posts:  1
Joined:  2008-04-06
 

After going to http://www.mysite.com/admin/sitemap/generate/sitemap_id/1 I get the following.  Does anyone else get this error. This command to generate the sitemap worked fine in 1.0.

SQLSTATE[42S22]Column not found1054 Unknown column 'e.is_active' in 'where clause'

#0 /home/slightpr/domains/slightprice.com/public_html/lib/Zend/Db/Statement.php(283): Zend_Db_Statement_Pdo->_execute(Array)
#1 /home/slightpr/domains/slightprice.com/public_html/lib/Zend/Db/Adapter/Abstract.php(406): Zend_Db_Statement->execute(Array)
#2 /home/slightpr/domains/slightprice.com/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(206): Zend_Db_Adapter_Abstract->query(Object(Varien_Db_Select), Array)
#3 /home/slightpr/domains/slightprice.com/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(193): Zend_Db_Adapter_Pdo_Abstract->query(Object(Varien_Db_Select), Array)
#4 /home/slightpr/domains/slightprice.com/public_html/app/code/core/Mage/Sitemap/Model/Mysql4/Catalog/Category.php(79): Varien_Db_Adapter_Pdo_Mysql->query(Object(Varien_Db_Select))
#5 /home/slightpr/domains/slightprice.com/public_html/app/code/core/Mage/Sitemap/Model/Sitemap.php(79): Mage_Sitemap_Model_Mysql4_Catalog_Category->getCollection('1')
#6 /home/slightpr/domains/slightprice.com/public_html/app/code/core/Mage/Adminhtml/controllers/SitemapController.php(206): Mage_Sitemap_Model_Sitemap->generateXml()
#7 /home/slightpr/domains/slightprice.com/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(343): Mage_Adminhtml_SitemapController->generateAction()
#8 /home/slightpr/domains/slightprice.com/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(137): Mage_Core_Controller_Varien_Action->dispatch('generate')
#9 /home/slightpr/domains/slightprice.com/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(168): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#10 /home/slightpr/domains/slightprice.com/public_html/app/Mage.php(420): Mage_Core_Controller_Varien_Front->dispatch()
#11 /home/slightpr/domains/slightprice.com/public_html/index.php(46): Mage::run()
#12 {main}

It creates my sitemap.xml but only 99kb and inside it looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
 
Magento Community Magento Community
Magento Community
Magento Community
 
matponta
Member
 
Total Posts:  39
Joined:  2008-05-20
Italy
 

I am having the exact same problem… did you ever fix it?

Mattia

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top