Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Fatal error: Uncaught exception ‘Zend_Db_Adapter_Exception’
 
berryb
Jr. Member
 
Total Posts:  5
Joined:  2008-07-02
 

I’ve been searching the boards to find an answer for this but haven’t found anyone that’s have this solved.

I have been working on designing and populating my catalog for the last few weeks.  One day out of the blue while in the admin adding a static block I went to check my site and got:

Fatal error: Uncaught exception ‘Zend_Db_Adapter_Exception’ .... etc…

Followed by the usual bunch of error code.  I was pretty bummed, as I’m not a hard core programmer.  My site is back up (for testing) but this seems to be happening randomly now - even though I haven’t done anything to the site!!

At first it was just the front end.  Now it happened today with the ADMIN.  After a few minutes refreshing the site and then googling a bunch of stuff it suddenly came back online.

Can anyone shed some light on what might be going on here?  It seems that other Magento users are having these “sudden crashes” as well.

Thanks so much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anton Makarenko
Magento Team
 
Avatar
Total Posts:  184
Joined:  2008-05-13
Los Angeles, CA
 

And what is behind the “.... etc… “? Looks like a bugreport, not a programming question.
Maybe You should report this ussue to tracker, providing as much useful info, as possible.
Thanks in forward.

 
Magento Community Magento Community
Magento Community
Magento Community
 
berryb
Jr. Member
 
Total Posts:  5
Joined:  2008-07-02
 

Ok… so everything started going fine again for a while, but all of the sudden it starts giving me the Fatal Errors again.  It will happen in the admin sometimes and on on the front end and visa versa.  Sometimes it happens when I’m simply navigating the site and sometimes it happens when I’m updating a product or something else in the admin.

Here’s what I just got, thoughts??:

Fatal errorUncaught exception 'Zend_Db_Adapter_Exception' with message 'SQLSTATE[HY000] [2013] Lost connection to MySQL server during query' in /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/lib/Zend/Db/Adapter/Pdo/Abstract.php:131 Stack trace#0 /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/lib/Varien/Db/Adapter/Pdo/Mysql.php(91): Zend_Db_Adapter_Pdo_Abstract->_connect() #1 /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/lib/Zend/Db/Adapter/Abstract.php(390): Varien_Db_Adapter_Pdo_Mysql->_connect() #2 /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/lib/Zend/Db/Adapter/Pdo/Abstract.php(206): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array) #3 /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(39): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8') #4 /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/app/code/core/Mage/Core/Model/Resource.php(77): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Objec in /nfs/c02/h06/mnt/46112/domains/theshearsource.com/html/lib/Zend/Db/Adapter/Pdo/Abstract.php on line 131
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top