Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

getChildHtml(’head’)?>
 
WTD
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2007-08-31
 

Using my PHP5 CGI on my server, trying to install just echo’s out..

getChildHtml(’head’)?>
getChildHtml(’header’)?>
getChildHtml(’store’)?>
getChildHtml(’breadcrumbs’)?>
getChildHtml(’left’)?>
getChildHtml(’global_messages’)?> getChildHtml(’content’)?>
getChildHtml(’footer’)?>
getChildHtml(’before_body_end’)?>

Anyone have any idea’s?? PHP CGI phpinfo page here http://www.akachanwear.com/testphpcgi/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tim Brayshaw
Jr. Member
 
Total Posts:  1
Joined:  2007-09-03
 

Hi, I had exactly the same problem. It’s to do with the

short_open_tag
ini setting. If you have the short_open_tag enabled, it should work okay.
 
Magento Community Magento Community
Magento Community
Magento Community
 
zevonjunior
Jr. Member
 
Total Posts:  4
Joined:  2007-09-19
 

Greetings!

I’ve just uploaded and installed Magento on my remote web server - Heart Internet - a LAMP setup with all the requisite LAMP goodies. And all the correct permissions as well. But - even with the short tags set to on (in the .htaccess file) I still got

getChildHtml(’head’)?>
getChildHtml(’header’)?>
getChildHtml(’store’)?>
getChildHtml(’breadcrumbs’)?>
getChildHtml(’left’)?>
getChildHtml(’global_messages’)?> getChildHtml(’content’)?>
getChildHtml(’footer’)?>
getChildHtml(’before_body_end’)?>

Not sure what to do; any takers?

TIA,
Adrian

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

It looks like you still have short open tags disabled. Recheck your settings.

 
Magento Community Magento Community
Magento Community
Magento Community
 
zevonjunior
Jr. Member
 
Total Posts:  4
Joined:  2007-09-19
 

You are right. Rats!

Okay, I don’t understand. In my Magento root folder there is a .htaccess file with a short_open_tag flag - see below - shouldn’t that do the job? Or do I need to do something in my root /public_html/ folder as well?

php_flag magic_quotes_gpc off
php_flag short_open_tag on

DirectoryIndex index.php

RewriteEngine on

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

Thanks much for the quick reply .. hoping for another one 8-)

-Adrian

RewriteRule .* index.php

 
Magento Community Magento Community
Magento Community
Magento Community
 
CougarNetworks
Jr. Member
 
Avatar
Total Posts:  5
Joined:  2008-01-09
Kent
 

I know this is an old thread but i will put the answer here anyway..

For Heart Internet users installing Magento:

create a .htaccess file in the root dir (ie http://www.mystore.com/magento)

put the following in it:

SetEnv DEFAULT_PHP_VERSION 5

DirectoryIndex index
.php

RewriteEngine on

RewriteBase 
/

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

next create a file named php5.ini and put in the following:

php_flag magic_quotes_gpc off
php_flag short_open_tag on

That should sort you out nicley.

I think Magento created a new .htaccess file during the install that replaced mine. I just removed the Magento created file and replaced it with my own.

Matt..

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top