Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

php5-cgi produces a 404 error with wrong path
 
Dotan
Jr. Member
 
Total Posts:  2
Joined:  2007-10-27
 

Hello all,

While trying to run Magento on a hosted server with php4, I tried using the php5-cgi workaround, but it produces a strange 404 error message:

Not Found
The requested URL 
/home/xxxx/domains/xxxx.xxx/public_html/eshop/magento/cgi-bin/php5-cgi/eshop/magento/index.php was not found on this server.

Additionallya 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

As you can see, the eshop folder is the folder in which Magento resides, and the cgi-bin is also placed in there. I tried to place the cgi-bin folder in the same level as the eshop folder, but it made no difference.

This is the .htaccess file:

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
</IfModule>

Action php5-cgi /home/xxxx/domains/xxxx.xxx/public_html/eshop/magento/cgi-bin/php5-cgi
 
AddHandler php5
-cgi .php

DirectoryIndex index
.php

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

Any ideas as for the source of the problem, and perhaps a solution?

I have no possibility to place the cgi-bin folder in the root directory of the server.

Thanks,
Dotan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi Dotan,

What does it display when you try to go to http://xxxx.xxx/eshop/magento/cgi-bin/php5-cgi ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dotan
Jr. Member
 
Total Posts:  2
Joined:  2007-10-27
 

Michael,

It actually doesn’t display anything. It opens a download dialog box for the php5-cgi, although both the file and its folder have full execution privileges.

At the meantime, we “solved” the problem by moving the installation to another server, but this is an issue that needs to be solved.

Dotan

 
Magento Community Magento Community
Magento Community
Magento Community
 
willsabstract
Jr. Member
 
Total Posts:  10
Joined:  2007-11-08
 

I was having the same problem on MediaTemple’s (DV) server. The resolution was to uncheck “CGI Support” in Plesk which I believe modifies the httpd.conf file. I hope this sets you in the right direction.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top