Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email

Magento Forum

InnoDB Tables <> MyIsam Tables
Frédéric Quié
Jr. Member
Total Posts:  1
Joined:  2007-09-01

Be Careful, Magento is using InnoDB Tables to install the Database.

So, if you don’t modify you my.cnf in your mysql folder it won’t work :

Open the configuration file in mysql folder - my.cnf in /xampp/mysql/bin and comment :


then uncomment :

innodb_data_home_dir = C:/xampp/mysql/data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:/xampp/mysql/data/
innodb_log_arch_dir = C:/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high

set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
set-variable = innodb_lock_wait_timeout=50

Magento Community Magento Community
Magento Community
Magento Community
Sr. Member
Total Posts:  126
Joined:  2007-08-31

I checked Magento setup scripts for SQL data and I can confirm it uses InnoDB tables by default, see app/code/core/Mage/Core/sql/core_setup/mysql4-install-0.6.0.php

However, I think the table format problem applies only to Mysql on Win32 or certain versions.
My Linux box runs Mysql 5.0.45 (debian package), it has InnoDB disabled (skip-innodb is still in the config file) and Magento created MyISAM tables on installation.

Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top