Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Magento Connect funktioniert nicht nicht nach einer LOCALE Installation
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

Ich war so dumm ein Magento Community Module zu installieren.
“ magento-community/Locale_Mage_community_it_IT “
http://www.magentocommerce.com/extension/377/magento-community-modules--italian-italy-language-pack

Dieses Modul hat sich nicht installiert. Es hat vielmehr meinen Magento Connect abgeschossen.
Leider passiert mir das IMMER bei “Magento Community Modulen” !!!

Wie kann man dieses Modul nun per Hand löschen?
Oder, wie kann man den Fehler beseitigen?

Die Fehlermeldung!

Exception caught:

WarningInvalid argument supplied for foreach() in /var/www/web1/html/magento_test/downloader/template/pear/packages.phtml on line 71

Backtrace
:

#0 /var/www/web1/html/magento_test/downloader/template/pear/packages.phtml(71): mageCoreErrorHandler(2, 'Invalid argumen...', '/var/www/web1/h...', 71, Array)
#1 /var/www/web1/html/magento_test/downloader/Maged/View.php(53): include('/var/www/web1/h...')
#2 /var/www/web1/html/magento_test/downloader/Maged/Controller.php(107): Maged_View->template('pear/packages.p...')
#3 /var/www/web1/html/magento_test/downloader/Maged/Controller.php(344): Maged_Controller->pearPackagesAction()
#4 /var/www/web1/html/magento_test/downloader/Maged/Controller.php(164): Maged_Controller->dispatch()
#5 /var/www/web1/html/magento_test/downloader/index.php(29): Maged_Controller::run()
#6 {main}
File Attachments
Magento Downloader.pdf  (File Size: 174KB - Downloads: 197)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Phoenix Medien - DE
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-05-29
Stuttgart, Germany
 

Hm… Kannst du “offizielle” Erweiterungen vom Magento-team installieren? Hast du von Anfang an mit Magento Downloader installiert, oder zuerst einfach hochgeladen und dann per Downloader Magento selbst aktualisiert?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

ofizielle kann ich installieren und ich habe von anfang an den downloader verwendet !

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phoenix Medien - DE
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-05-29
Stuttgart, Germany
 

Es gibt das Paket in der Version vom 23.07, ist es das was du installiert hattest?

Wenn ja, kannst du mal das Pear-Packate im Forum anhängen? (Hab keine Lust es zu installieren und den Shop zu zerschießen wink ) Dann könnte ich es inspizieren.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

Ich verstehe den Post nicht.
Welches Paket meinst du denn ? Das Sprachpaket ??
Oder dem Downloader?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phoenix Medien - DE
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-05-29
Stuttgart, Germany
 

in /downloader/pearlib/download werden alle installierten Pakete zwischengespeichert, davon hätte ich gern das deutsche oder italienische Sprachpaket. wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

Ich habe das System komplett neu installiert :-(
Das italienische ist also schon wieder weg! grin

Aber ich werde heute abend ein Test-System aufsetzen ..
ein Magentoschop, der sich auf knopfdruck resetet ...
dann kann ich dir morgen auch gerne einen zugriff (ftp+admin) geben…
wäre klasse, wenn das zeitlich für dich OK ist ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

Ich habe das System komplett neu installiert :-(
Das italienische ist also schon wieder weg!

Aber ich werde heute abend ein Test-System aufsetzen ..
ein Magentoschop, der sich auf knopfdruck resetet ...
dann kann ich dir morgen auch gerne einen zugriff (ftp+admin) geben…
wäre klasse, wenn das zeitlich für dich OK ist ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phoenix Medien - DE
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-05-29
Stuttgart, Germany
 

Das wäre OK, im deutschen paket hab ich übrigens mittlerweile festgestellt, daß alle Dateien doppelt oder vierfach drin sind. Es könnte sein, daß das der Grund ist.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

Ich habe hier noch das Megento_Core ... German paket…
Guck mal ob es so aussieht wie das aus der community…

File Attachments
Locale_Mage_Core_de_DE-1.0.18801.tgz  (File Size: 378KB - Downloads: 76)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Phoenix Medien - DE
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-05-29
Stuttgart, Germany
 

Hm… Da sind auch mehrere Dateien mehrfach vorhanden.

Bei einer Neuinstallation sollte auch nicht mehr das alte Sprachpaket dazwischenfummeln und dennoch geht es kaputt. Auf jeden Fall werde ich mal die Dateien durch ein diff-Programm durchjagen.

Kommt der Fehler übrigens nach der Installation von ALLEN Modulen, oder nur von Sprachpaketen?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

ich habe immer das problem, wenn es eine community paket ist ....

 
Magento Community Magento Community
Magento Community
Magento Community
 
amay
Jr. Member
 
Total Posts:  5
Joined:  2008-06-15
 

Hatte dasselbe Problem und eine Lösung gefunden. Das Problem entsteht anscheinend durch den Magento Downloader =>

1) entweder den Magento-Downloader nicht verwenden und Magento selber herunterladen und am Server entpacken, dann tritt das Problem nicht auf! ODER
2) ins magento/downloader/pearlib-Verzeichnis wechseln und “./clean” ausführen. Dann sind alle Erweiterungen in der Magento Connect-Ansicht weg. Nachher die gewünschten Erweiterungen installieren - sollte funktionieren.

Kann diese Lösungen jemand verifizieren?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

Ich kann deine Ausführungen nicht nachvollziehen
Was ist das für ein Befehl CLEAN ???

 
Magento Community Magento Community
Magento Community
Magento Community
 
kulimuli
Sr. Member
 
Total Posts:  151
Joined:  2008-03-31
Linz, Oberösterreich
 

Hi,

das ./clean bedeutet das das script “clean” im aktuellen Pfad gestartet und ausgeführt wird, dies ist kein Unix Befehl, sondern ein bash Script welches von magentocommerce bereitgestellt wird.

wenn Du im Pfad downloader/pearlib bist, gebe ./clean ein…

LG
kulimuli

 
Magento Community Magento Community
Magento Community
Magento Community
 
Aneas
Member
 
Avatar
Total Posts:  61
Joined:  2008-07-12
San Vito Chietino, Italy
 

aha ... danke das hat mir gefehlt ...
und sollte ich das machen BEVOR ich den downloader anschmeisse ??
Oder nachdem ich die Fehlermeldung bekommen habe ??

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2