Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How do I fix this error? 
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

Should I replace the files mentioned?

Print Shipment Error…

Has anyone else run into this err

Cannot create image resourceFile extension not known or unsupported type.

#0 /var/www/vhosts/domain.com/httpdocs/lib/Zend/Pdf/Image.php(131): Zend_Pdf_Resource_ImageFactory::factory('/var/www/vhosts...')
#1 /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Sales/Model/Order/Pdf/Abstract.php(67): Zend_Pdf_Image::imageWithPath('/var/www/vhosts...')
#2 /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Sales/Model/Order/Pdf/Shipment.php(40): Mage_Sales_Model_Order_Pdf_Abstract->insertLogo(Object(Zend_Pdf_Page))
#3 /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Adminhtml/controllers/Sales/Order/ShipmentController.php(361): Mage_Sales_Model_Order_Pdf_Shipment->getPdf(Array)
#4 /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(342): Mage_Adminhtml_Sales_Order_ShipmentController->printAction()
#5 /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(148): Mage_Core_Controller_Varien_Action->dispatch('print')
#6 /var/www/vhosts/domain.com/httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(146): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#7 /var/www/vhosts/domain.com/httpdocs/app/Mage.php(427): Mage_Core_Controller_Varien_Front->dispatch()
#8 /var/www/vhosts/domain.com/httpdocs/index.php(46): Mage::run()
#9 {main}

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiaraweb
Guru
 
Avatar
Total Posts:  721
Joined:  2008-03-21
Aviano ~ Italy
 

Hi

it is a problem of the format of logo (have you a gif?), try tu use png image!

 
Magento Community Magento Community
Magento Community
Magento Community
 
bzsaw
Sr. Member
 
Avatar
Total Posts:  141
Joined:  2008-02-13
 

Yep.. that was it.. changed it to a JPG and it worked fine.

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top