Magento Forum

Basic importing from .csv - Yes I tried searching. 
 
pspahn
Jr. Member
 
Total Posts:  30
Joined:  2010-03-07
 

Disclaimer: I tried searching forums, searching “import” gives me over 500 results, however, when I try to navigate to page 2, I am told that page is not found. Advanced search is also broken.

As I just convinced the people funding my paycheck that a $4000 deposit to the developers of our Magento site is the right way to go, I sure hope this doesn’t bite me in the rear later. I am having second thoughts about Magento.

Anyways.

I am trying to do some basic product imports. My procedure:
1. Export .csv from magento. It’s blank and just has headers.
2. Open with OpenOffice, default choices during import, just clicking OK OK OK...etc.
3. Built one test product, entering values for required fields.
4. Import into magento.

At this point, I had no problems, the product showed up and everything was swell.

5. Delete test product via dashboard.
6. Copy/paste data from my .csv that contains all my products. Did this for one record only.
7. Did some find&replace;to format things according to how magento will like them (ex. Changed sku to lowercase and added .html for url_path)
8. Import into magento.

At this point, still no problems. The imported .csv had 2 products, the test product with data typed into cells manually, and the real product with data copy/pasted.

9. Delete both products via dashboard.
10. Repeat steps 5-8, however, this time copy/pasting a dozen or so columnar values at once instead of just the one cell for one product.
11. When importing into magento, I get:

Starting profile execution, please wait…
Warning: Please don’t close window during importing/exporting data
Starting Mage_Dataflow_Model_Convert_Parser_Csv :: parse
Found 13 rows
Starting catalog/convert_adapter_product :: parse
(this line shows Error icon and is red, but no text)
Processed 0% 0/13 records
Imported 0 records
Please wait while we are refreshing indexes.
Finished profile execution.

At this point, my product tables are broken. If I try to view “all products” in front-end, I get an error. In the back-end, all the products show up under Manage Products, but are not given proper values for visibility (and maybe other fields?) even though I put the proper values in the .csv file prior to import.

I can delete all products from back-end and everything goes back to step 1.

I have tried all prior steps with and without the magento header in the import.csv. I have tried all prior steps using .xml as well.

I will include sample files. (import_14rec.csv is what fails. The exact same file with only rows 1-3 is successful, shrub-decid.csv is an export from our HP-UX server, I am copy/pasting only a few fields, those being SIGNCODE, DESCRIPTION, COMMON NAME, and BOTANICALNAME.)

Okay, nevermind, uploading files also does not seem to work. Is there a special browser I should be using to actually use magento’s website? The latest versions of Chrome, IE, and FF all appear to not actually upload files.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top