Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

There has been an error processing your request.  Email, User Name already exists
 
theonlycore4
Jr. Member
 
Total Posts:  21
Joined:  2008-05-21
 

Please help.

I was trying to switch to another theme. Here’s what I did. I copy/pasted the following directories:

app/design/frontend/default and created a second interface by pasting all contents of default into a new interface folder (in the same directory already cited) called mystore_interface.

I did the same for the skin/frontend/default folder.

Now, when I go to switch the template in the admin system/configuration/design/Templates (to say “mystore_interface"), and press save, then it says this:

Email, User Name already exists
Trace:
#0 /home/champ13/public_html/store/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(465): Mage::throwException(’Email, User Nam...’)
#1 /home/champ13/public_html/store/app/code/core/Mage/Core/Model/Mysql4/Abstract.php(337): Mage_Core_Model_Mysql4_Abstract->_checkUnique(Object(Mage_Admin_Model_User))
#2 /home/champ13/public_html/store/app/code/core/Mage/Admin/Model/User.php(62): Mage_Core_Model_Mysql4_Abstract->save(Object(Mage_Admin_Model_User))
#3 /home/champ13/public_html/store/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(248): Mage_Admin_Model_User->save()
#4 /home/champ13/public_html/store/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(133): Mage_Adminhtml_System_ConfigController->_saveState(Array)
#5 /home/champ13/public_html/store/app/code/core/Mage/Core/Controller/Varien/Action.php(342): Mage_Adminhtml_System_ConfigController->saveAction()
#6 /home/champ13/public_html/store/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(148): Mage_Core_Controller_Varien_Action->dispatch(’save’)
#7 /home/champ13/public_html/store/app/code/core/Mage/Core/Controller/Varien/Front.php(146): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#8 /home/champ13/public_html/store/app/Mage.php(427): Mage_Core_Controller_Varien_Front->dispatch()
#9 /home/champ13/public_html/store/index.php(40): Mage::run()
#10 {main}

Can someone please help me fix this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Magento4me
Member
 
Avatar
Total Posts:  39
Joined:  2008-04-01
Amsterdam, The Netherlands
 

Don’t know if this is still an issue (hope not), but for the record I had the same problem. Then I remembered that I was adding users at the Permissions menu earlier that day (system > permissions > users). So I went back and I noticed that there was an ‘empty’ user in there. It had no username, first name etc. So I deleted this empty user (Delete User) and after that the problem was solved. No more Email, User Name already exists-messages.

Thanks,
Frank

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top