Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

HELP! I get this “There has been an error processing your request.” when accessing admin panel. 
 
oxygen
Member
 
Total Posts:  69
Joined:  2008-06-09
 

hi,
Could someone help me please? I get this message when I try to go into my admin area. I didn’t do anything. I am the only admin user.
Now I cannot even go in via http://www.mystore.com/admin.
I am using version 1.0.19870.1.
Really appreciate if you could help me to solve this.

Thank you.
regards

Invalid attribute requestedlastname
Trace
:
#0 /home/mystore/public_html/app/code/core/Mage/Eav/Model/Entity/Collection/Abstract.php(330): Mage::exception('Mage_Eav', 'Invalid attribu...')
#1 /home/mystore/public_html/app/code/core/Mage/Reports/Model/Mysql4/Customer/Collection.php(61): Mage_Eav_Model_Entity_Collection_Abstract->addAttributeToSelect('lastname')
#2 /home/mystore/public_html/app/code/core/Mage/Adminhtml/Block/Dashboard/Tab/Customers/Newest.php(41): Mage_Reports_Model_Mysql4_Customer_Collection->addCustomerName()
#3 /home/mystore/public_html/app/code/core/Mage/Adminhtml/Block/Widget/Grid.php(438): Mage_Adminhtml_Block_Dashboard_Tab_Customers_Newest->_prepareCollection()
#4 /home/mystore/public_html/app/code/core/Mage/Adminhtml/Block/Widget/Grid.php(444): Mage_Adminhtml_Block_Widget_Grid->_prepareGrid()
#5 /home/mystore/public_html/app/code/core/Mage/Core/Block/Abstract.php(553): Mage_Adminhtml_Block_Widget_Grid->_beforeToHtml()
#6 /home/mystore/public_html/app/code/core/Mage/Adminhtml/Block/Dashboard/Grids.php(54): Mage_Core_Block_Abstract->toHtml()
#7 /home/mystore/public_html/app/code/core/Mage/Core/Block/Abstract.php(193): Mage_Adminhtml_Block_Dashboard_Grids->_prepareLayout()
#8 /home/mystore/public_html/app/code/core/Mage/Core/Model/Layout.php(402): Mage_Core_Block_Abstract->setLayout(Object(Mage_Core_Model_Layout))
#9 /home/mystore/public_html/app/code/core/Mage/Adminhtml/Block/Dashboard.php(66): Mage_Core_Model_Layout->createBlock('adminhtml/dashb...')
#10 /home/mystore/public_html/app/code/core/Mage/Core/Block/Abstract.php(193): Mage_Adminhtml_Block_Dashboard->_prepareLayout()
#11 /home/mystore/public_html/app/code/core/Mage/Core/Model/Layout.php(402): Mage_Core_Block_Abstract->setLayout(Object(Mage_Core_Model_Layout))
#12 /home/mystore/public_html/app/code/core/Mage/Adminhtml/controllers/DashboardController.php(35): Mage_Core_Model_Layout->createBlock('adminhtml/dashb...', 'dashboard')
#13 /home/mystore/public_html/app/code/core/Mage/Core/Controller/Varien/Action.php(342): Mage_Adminhtml_DashboardController->indexAction()
#14 /home/mystore/public_html/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(148): Mage_Core_Controller_Varien_Action->dispatch('index')
#15 /home/mystore/public_html/app/code/core/Mage/Core/Controller/Varien/Front.php(146): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#16 /home/mystore/public_html/app/Mage.php(427): Mage_Core_Controller_Varien_Front->dispatch()
#17 /home/mystore/public_html/index.php(40): Mage::run()
#18 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
oxygen
Member
 
Total Posts:  69
Joined:  2008-06-09
 

hi all,
I managed to get into admin by deleting var/cache.
I still do not know what caused it.
Is my database corrupted somewhere?
Is there a way I can verify the integrity of my system?

Thank you.
regards

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top