Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error : PHP Extension “pdo_mysql” must be loaded
 
Saud
Jr. Member
 
Total Posts:  20
Joined:  2008-07-04
 

I m getting this error while installing “PHP Extension “pdo_mysql” must be loaded” and i chat with my hosting provider 3ix.com and they said that pdo_mysql is not allowed on their server. Is there any way to install this scipt ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

I do not think it is possible. Have you asked them whether they can install it in your server or move you to a server which has pdo_mysql installed?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Saud
Jr. Member
 
Total Posts:  20
Joined:  2008-07-04
 

They said they cannot install it for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

I see. If that is the case I think move on is the only solution for Magento to work.
Unless there are other members who knows how to work around this. Have you searched the forum for solutions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Saud
Jr. Member
 
Total Posts:  20
Joined:  2008-07-04
 

Ya i searched the forum and I think I have to continue using oscommerce. This is a very nice script and i love the interface and everything. Why this script is not written without the use of that plugin????

 
Magento Community Magento Community
Magento Community
Magento Community
 
Saud
Jr. Member
 
Total Posts:  20
Joined:  2008-07-04
 

pdo_mysql is also required with the beta version ??

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Do you mean the beta version of 1.1.0?
If so, yes. pdo_mysql is required for all versions of Magento Commerce regardless of alpha, beta or stable state.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Saud
Jr. Member
 
Total Posts:  20
Joined:  2008-07-04
 

My websites are hosted with many different hosting companies and only one host support pdo_mysql.
I think the moderators should create a different alternative to this pdo_mysql otherwise most people will not be able to use MC

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

If you have a host which supports pdo_mysql, you can only host Magento there.
Have you checked to see whether that host fulfills all the requirements for Magento to run smoothly?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top