Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Products Quantity doesn’t show up in category front-end even though they are there. (Screenshots included)
 
eliteeternity
Member
 
Avatar
Total Posts:  74
Joined:  2008-07-16
 

So I’m not sure what’s going on, but this is really pissing me off. I can create two brand new products on a brand new installation and I’ll put them in a category. They show up on the back end in the right category, but the front end they don’t show up. They do show up, but only when you click on the category itself. I hope my two screen shots explain what I fail to textually explain. Either there is something really buggy about this software, or I’m a complete and total noob. Somebody please shed some light on the subject.

Image Attachments
cat2.pngcat1.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
eliteeternity
Member
 
Avatar
Total Posts:  74
Joined:  2008-07-16
 

Well, let me answer my own question. I hope this helps somebody in my situation. After countless of hours of trying to figure this out, I found that if you disable the category in the admin and then enable it, it will show the correct quantity on the front end. I haven’t tried this for mass import, but I’ll update this post when I try.

EDIT: Make sure your product has the “website” selected. If it’s not, the products won’t show up. Seems simple enough, but it had me stumped for the longest time.
Catalog > Manage Products > Choose Product > *Under “Product Information” > Websites > Check the box next to the website > Save

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top