Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

more errors after a php server update
 
Melinda
Member
 
Total Posts:  49
Joined:  2007-08-31
 

http://www.designhosting.us/magento/
now gives this error:

WarningInvalid argument supplied for foreach() in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Backend/File.php on line 281
[0] in Zend_Cache_Backend_File
->remove("config_global"in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Backend/File.php on line 225
[1] in Zend_Cache_Backend_File
->save("

White page that doesn’t work.

Admin gives these errors:

WarningInvalid argument supplied for foreach() in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Backend/File.php on line 398
[0] in Zend_Cache_Backend_File
->_clean("/var/www/vhosts/designhosting.us/httpdocs/magento/var/cache/""old"Array[0]in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Backend/File.php on line 307
[1] in Zend_Cache_Backend_File
->clean("old"Array[0]in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Core.php on line 386
[2] in Zend_Cache_Core
->clean("old"in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Core.php on line 321
[3] in Zend_Cache_Core
->save("
/var/www/vhosts/designhosting.us/httpdocs/magento/lib/Varien/Simplexml/Config.php on line 273
[4] in Varien_Simplexml_Config->saveCache() in /var/www/vhosts/designhosting.us/httpdocs/magento/app/code/core/Mage/Core/Model/Config.php on line 146
[5] in Mage_Core_Model_Config->init(NULL) in /var/www/vhosts/designhosting.us/httpdocs/magento/app/code/core/Mage/Core/Model/App.php on line 126
[6] in Mage_Core_Model_App->init("
base", NULL) in /var/www/vhosts/designhosting.us/httpdocs/magento/app/Mage.php on line 357
[7] in Mage::app("
base", NULL) in /var/www/vhosts/designhosting.us/httpdocs/magento/app/Mage.php on line 377
[8] in Mage::run("
base") in /var/www/vhosts/designhosting.us/httpdocs/magento/index.php on line 28

If I refresh this page then I get this:

WarningInvalid argument supplied for foreach() in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Backend/File.php on line 281
[0] in Zend_Cache_Backend_File
->remove("config_global"in /var/www/vhosts/designhosting.us/httpdocs/magento/lib/Zend/Cache/Backend/File.php on line 225
[1] in Zend_Cache_Backend_File
->save("

Gives a white page and none of the links work.

why?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

this looks like corrupted cache files, delete var/cache folder and see if it helps.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Melinda
Member
 
Total Posts:  49
Joined:  2007-08-31
 

I removed the cache directory and emptied the sessions folder and now it is back correctly.  I did try to upload an image to a category and get this error message:
Unable to create directory ‘/var/www/vhosts/designhosting.us/httpdocs/magento/media/catalog/category/1/.’.

I went into the server and the “1” folder it made had the wrong permissions plus the owner and group was apache so when I changed that folder then the image uploaded.

Also I put in a product with images and it is showing properly in the store.

I love your quote ... - I would love to change the world, but they won’t give me the source code -

Thanks Moshe!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top