Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Modify Box poll in the modern theme
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

Hi
i have changed the position of the box poll changing <reference name="right"> with <reference name="left">.

The problem is which when i go in the template-file of the poll (poll/result.phtml), the changes don’t works....

The cache is disabled..

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

I think you need to refresh the cache. Just did a test, it works for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

don’t works…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

<default>

<!-- Mage_Poll -->
<reference name="left">
<block type="poll/activePoll" name="right.poll">
<action method="setPollTemplate"><template>poll/active.phtml</template><type>poll</type></action>
<action method="setPollTemplate"><template>poll/result.phtml</template><type>results</type></action>
</block>
</reference>

</default>

is correct?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

that’s correct! Maybe try to refresh it few more time? It works for me sometimes, especially with Safari browser.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

I have tried different times with more browsers, refresh the cache...etc…
it doesn’t go.. each change that I make phtml to the file is as if there was not

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Just a thought here. I see Modern theme uses 2column-left only, so the poll never get loaded because ‘right’ is not used. Maybe somewhere needs to edit in order for it to show up.?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

but have done him! I have modified the “reference name” from right to left… or is there other to be done?

I with the other box have done so and i have not given me problems…

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

I think I know where the problem is.

You have :
<!-- Mage_Poll -->
<reference name="left">
<block type="poll/activePoll" name=”right.poll">
.....
</block>

try changing it to name=”left.poll">

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

i have tried also this… but.. don’t work

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

nothing??

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

I have tried with another installation with a modern and I have ascertained a thing:
bringing to the left the poll-box with the file xml, and modifying the file result.phtml, the poll he is seen to the left, but the standard poll is seen, what asks the preferred color, also not being us in the database (and it replaces that existing).
What happens? is it a bug?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Poll management is in the admin/cms.

This just reminds me why you couldn’t get it move to the left. Because I see there is ‘Visible In website/stores option.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Black Cat
Mentor
 
Avatar
Total Posts:  3481
Joined:  2008-02-14
Assemini / Cagliari (Italy)
 

we are not understood there… I in my store have only a poll that is not that of default.
The problem is that modifying the template (result.phtml) the poll of default again appears from the nothing, also not existing in my store anymore. the why it happens? boh.. does someone know how to help me?

PS:and the template of mini-poll not is modifiy

 
Magento Community Magento Community
Magento Community
Magento Community
 
ecommerce-store
Sr. Member
 
Avatar
Total Posts:  181
Joined:  2008-04-16
Roma
 

i have the same problem, f**

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

I wanted to look into it but I can’t even get the modern theme loaded properly. I have a version from v1.1 trunk, and it won’t load in my v0.1987 installation.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2