Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Install error … 3,541? 
 
Solar Frenzy
Member
 
Avatar
Total Posts:  48
Joined:  2007-09-05
London
 

Having real install errors but this one stumps me.

ver. 0.6.13160

Had to install everything 3 times before finally getting access to the admin area.

The actual store, however, is throwing up:
Fatal error: Call to a member function setName() on a non-object in /home/myserver/public_html/pathto/magento/app/code/core/Mage/Core/Model/Layout.php on line 347

Line 347 is $blockObj->setName($blockName);

I have checked that all files are installed, for the fifth time, and they are.

This morning, after various amounts of times trying to install, I downloaded a fresh (full) version, uploaded it (3rd time this time).
Database is brand new as well.

thanks in advance.

edit >> if it makes any difference, the root level htaccess is set as:
<IfModule mod_php5.c>
php_flag magic_quotes_gpc off
php_flag short_open_tag on
</IfModule>

DirectoryIndex index.php

RewriteEngine on

#RewriteBase /

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php
addHandler application/x-httpd-php5 .php

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top