Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Order status dosnt change after receiving IPN
 
basedesignsffs
Member
 
Avatar
Total Posts:  31
Joined:  2007-12-18
 

Hi,

I have been testing paypal standard on my site, i have set the ‘New Order Status’ to ‘Pending’. So when an order is placed it is set as pending.. and the way I understand it is after the customer pays through paypal, the order status should be automaticaly changed to ‘Processing’, but its just staying as ‘Pending’ so I have no easy way of knowing if the payment has been received which sucks. If I view the actual order it says the IPN was received in the comments history section… so its definately working, just not changing the status. Is there a setting somewhere that dictates status changes?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
basedesignsffs
Member
 
Avatar
Total Posts:  31
Joined:  2007-12-18
 

nevermind, tried it with live accounts and it worked just fine.. no way in hell could i get it to work with sandbox accounts though.

 
Magento Community Magento Community
Magento Community
Magento Community
 
acketon
Jr. Member
 
Total Posts:  14
Joined:  2008-06-28
 

I posted about this a couple days ago because I was having the same problem. After figuring out my problem I wrote a Wiki on setting up PayPal Standard:
http://www.magentocommerce.com/wiki/how_to/paypal_standard_payments_setup_with_ipn

 
Magento Community Magento Community
Magento Community
Magento Community
 
djackso1
Jr. Member
 
Total Posts:  1
Joined:  2008-05-22
 
johnmatrix - 09 July 2008 04:42 AM

nevermind, tried it with live accounts and it worked just fine.. no way in hell could i get it to work with sandbox accounts though.

I also was unable to get IPN to work with the sandbox account, but works as expected with a live account.  I’m using the exact same settings.

Anyone have any ideas?  Could be a browser cookie/cache issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
acketon
Jr. Member
 
Total Posts:  14
Joined:  2008-06-28
 

can you post all of the settings you are using? I might be able to help.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top