Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Object not found! {solved}
 
thcreations
Jr. Member
 
Total Posts:  5
Joined:  2008-07-08
 

I finally got magento installed under xampp, and from the store front every link brings me to “Object Not Found!”

Any suggestions?

 
Magento Community Magento Community
Magento Community
Magento Community
 
adimagento
Guru
 
Avatar
Total Posts:  626
Joined:  2007-08-29
Los Angeles, CA
 

Sounds like your URL rewrite functionality is disabled.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thcreations
Jr. Member
 
Total Posts:  5
Joined:  2008-07-08
 

Can anybody tell me how to enable URL rewrite functionality? or point me to an existing post?

Thanks for the help

 
Magento Community Magento Community
Magento Community
Magento Community
 
adimagento
Guru
 
Avatar
Total Posts:  626
Joined:  2007-08-29
Los Angeles, CA
 

You can either speak to your hosting provider to turn it on for you on the server side or just disable this feature from the Magento Admin side under configuration > web > SEO

 
Magento Community Magento Community
Magento Community
Magento Community
 
diveeco
Jr. Member
 
Total Posts:  1
Joined:  2008-07-01
 

I ran into the same problems with installing the sample data.  After a successful installation of Magento with sample data, every link I click on the homepage was showing “Object Not Found Error!”.  After 4 installation attempts, I figured out to solve my problem thanks to Adi’s recommendations above.  Turns our my opensuse 10.3 server did not have mod_write enabled. 

Here are some solutions that I recommend anyone having the same problems: (the steps below assumes that sample data was installed successfully prior to your Magento installation.)

1. If mod_rewrite is enabled in your Apache configuration, then check enable Mod_Rewrite during the Magento installation process. This setup should work fine with the sample data package.  (NOTE: the Magento sample data package or Magento installation have SEO optimization setting ENABLED which utilizes the Apache Mod_Rewrite module.)

2. If mod_rewrite is NOT enabled in your Apache configuration, do not enable Mod_Rewrite during the Magento installation process.  Once the Magento installation is complete, login to the Magento Administration control panel and disable SEO optimization in the system configuration.  See steps below:

- Got to this page - http://localhost/index.php/admin/system_config/edit/section/web/
- Expand “Search Engines Optimization” on right column
- Change “Use Web Server Rewrites” from YES to NO
- Save Config

This should fix the Object Not Found errors.  Let me know if this works for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thcreations
Jr. Member
 
Total Posts:  5
Joined:  2008-07-08
 

That Worked Adi, You Rock!

 
Magento Community Magento Community
Magento Community
Magento Community
 
den_piero
Jr. Member
 
Total Posts:  9
Joined:  2008-09-14
Jakarta, Indonesia
 

Need help Adi, please....
XAMPP 1.6.7
Magento 1.1.5, Sample Data 1.1.2
mod_rewrite enabled on ..\xampp\apache\conf\httpd.conf before magento installed, but i still have “Object not found”
i disabled the SEO, “Object not found” disappeared and change to a page where these messages appeared

“Whoops, our bad…
The page you requested was not found, and we have a fine guess why.
If you typed the URL directly, please make sure the spelling is correct.
If you clicked on a link to get here, the link is outdated.”

Is it something i missed?

 
Magento Community Magento Community
Magento Community
Magento Community
 
den_piero
Jr. Member
 
Total Posts:  9
Joined:  2008-09-14
Jakarta, Indonesia
 

Whoops, my bad…
after i enabled mod_rewrite, i edit the .htaccess on magento installation folder for the #RewriteBase /magento by deleting # (commented sign)
i re-enabled SEO, and VOILA! it works!
But remain my problem is the “Home"-"Best Selling Products” direct me not to the product pages but still to the “404”, i believe i’m missing sumthing..do i?
you would be soooo cute if you can help me on this Adi, sorry i’m new at these stuff.
Thanx b4
ohh 1 more thing, MAGENTO ROCKS! can’t wait...any longer…

 
Magento Community Magento Community
Magento Community
Magento Community
 
den_piero
Jr. Member
 
Total Posts:  9
Joined:  2008-09-14
Jakarta, Indonesia
 

wink you are soooo cute! Thanx Adi for the solution, i found it in your post “Refresh caches”, wow you are i said.  wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
xgabo
Member
 
Total Posts:  40
Joined:  2008-09-11
 

I use simple scripts (provided my my hosting company) to install magento on my host.  I need to have seo urls on for an app Im using, but when its on I get an error >page not found< on any page other than the index.  what settings or code do I need to change.  I see that some people are talking about Apache but I dont know what or where that code is.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sebastian123
Jr. Member
 
Total Posts:  5
Joined:  2008-10-17
 

My problem:

If ”Use Web Server Rewrites”: Yes
The URLs are fine, but every link brings me to “Object Not Found!”

If ”Use Web Server Rewrites”: No
The links work but the URLs are wrong, for example:
site.com/index.php/account

I have mod_rewrite enabled on my server.

Any help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
xgabo
Member
 
Total Posts:  40
Joined:  2008-09-11
 

In admin-configure- turn on seo rewrites
rename the htaccess.txt to .htaccess and replace the piece of the old code with this new one (just look for the code that looks similar)
make sure to save an original copy before you go saving over your htaccess file!!

“############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

-------------------------------------------------------------------------------------------------------------------------------------------------
Emarketingmaterial.com A Magento design company..  Coming soon !!

 
Magento Community Magento Community
Magento Community
Magento Community
 
sebastian123
Jr. Member
 
Total Posts:  5
Joined:  2008-10-17
 

thanks but that didn’t work, in fact my htaccess is exactly the same as that one…

I’m stuck with this for almost a week

 
Magento Community Magento Community
Magento Community
Magento Community
 
xgabo
Member
 
Total Posts:  40
Joined:  2008-09-11
 

Is this what your htaccess file looks like?

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 120M
php_value memory_limit 140M
php_value max_execution_time 20000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

 
Magento Community Magento Community
Magento Community
Magento Community
 
xgabo
Member
 
Total Posts:  40
Joined:  2008-09-11
 

You can also check out this forum. http://www.magentocommerce.com/boards/viewthread/9401/P75/
its about getting a data feed to work, but this is where I found out how to make seo urls work.  read post written by turbo1

 
Magento Community Magento Community
Magento Community
Magento Community
 
davidvbski2
Jr. Member
 
Total Posts:  1
Joined:  2008-10-30
 

I had issues when I put php5-cgi in /srv/www/cgi-bin. It kept redirecting to http://server/index.php/install when it should have redirected to
http://server/magento/index.php/install and as I tweaked things I got Error 500, and other errors.

Then I copied php5-cgi to <server root>/magento/cgi-bin/php5-cgi and things started working!

Thanks to everyone and to Adi for moderating…

David
PS: Hey Adi, haven’t I seen you on the vb courts or maybe mountain biking?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2