Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Probleme mit Web Service API
 
OliverFuerst
Jr. Member
 
Total Posts:  4
Joined:  2008-07-08
 

Hallo,

als bekannt gemacht wurde, das die WebService API in der Version 1.1 nun da ist, habe ich mich gefühlt, wie als kleiner Junge am Weihnachtsabend. Leider kam schnell die Ernüchterung: Es geht bei mir nicht.

Problem ist, das ich, wenn ich auf die WSDL zugreiffen möchte (http:\\shopurl\api\soap\?wsdl), nur eine Fehlermeldung erhalte:

<SOAP-ENV:Envelope>
  <
SOAP-ENV:Body>
    <
SOAP-ENV:Fault>
      <
faultcode>WSDL</faultcode>
      <
faultstring>SOAP-ERRORParsing WSDLCouldn't load from 'http://shopurl/api/soap/index/wsdl/1/'</faultstring>
    
</SOAP-ENV:Fault>
  </
SOAP-ENV:Body>
</
SOAP-ENV:Envelope>

Kann mir jemand sagen, was ich verkehrt mache ?

Auch das php Beispiel aus den Kommentaren zur Dokumentationsveröffentlichung (http://weblog.pixeldreamz.com/2008/07/06/magento-und-die-api/ ) läuft bei mir nicht.

Grüsse

Oliver

 
Magento Community Magento Community
Magento Community
Magento Community
 
thE_iNviNciblE
Sr. Member
 
Avatar
Total Posts:  220
Joined:  2008-01-09
Oldenburg
 

Hallo,

danke für den hilfreichen link grin

hast du dir die neue doku schonmal angesehen ?

Magento API

Hast du die allerneuste Alpha Release aus dem SVN ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael F.
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-07-05
Bavaria
 

Das Problem hab ich zwar nicht - die WSDL wird einwandfrei angezeigt.

Eigentlich hatte ich mein Problem gepostet (Access Denied) - hab jetzt jedoch die Gruppenberechtigung auf “Alle” gesetzt, und das Problem war behoben.

Die API funzt also mit SOAP soweit mal ganz gut - werd mich mal jetzt an die Anbindung an die WaWi machen

Gruß
Michael

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jeena Paradies
Jr. Member
 
Avatar
Total Posts:  22
Joined:  2008-03-10
 

Hm doof, ich bekomme die selbe fehlermeldung aber leider half novalis code nicht :-( jemand noch eine andere Idee?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jstrobel
Jr. Member
 
Total Posts:  3
Joined:  2007-08-31
 

Wurde das Beispiel bei mir (pixeldreamz.com) per copy&paste;aus der Seite kopiert, funktionierte das nicht und lieferte einen “Invalid api path”. Ich habe das leider erst heute gemerkt, jetzt aber ein Plugin im Einsatz was das Wordpress-eigene ersetzen von Zeichen unterbindet und so das Beispiel lauffähig macht.

@Oliver: Kannst du mal dein Beispiel posten? Ich find spontan das der Pfad in der Fehlermeldung nicht richtig aussieht.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top