Magento Forum

   
URL questions
 
gadgetplay
Jr. Member
 
Avatar
Total Posts:  30
Joined:  2008-05-03
Basingstoke, UK
 

Hi guys,

I’m hoping someone has experienced the same problem and/or knows the solution to this one?

I just done a fresh installation of the latest version of Magento. You can see over at http://www.gadgetplay.co.uk

2. If you hover over a link (e.g. My Account - http://www.gadgetplay.co.uk/customer/account/) and click on it you get an Error 404 page.

Why am I getting this error and what would the solution be?

3. Also if I go into Admin, the URL appear like this: http://www.gadgetplay.co.uk/index.php/admin/dashboard/

Why is the URL showing the index.php part. Shouldn’t it just be http://www.gadgetplay.co.uk/admin/dashboard/?

Thanks all that can help in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ODB
Sr. Member
 
Avatar
Total Posts:  142
Joined:  2008-02-06
London
 

The ‘index.php’ on front and backend will disappear if you have server rewrites enabled (iirc). It sounds like something to do with your rewrites is hosed, maybe your .htaccess file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gadgetplay
Jr. Member
 
Avatar
Total Posts:  30
Joined:  2008-05-03
Basingstoke, UK
 

Thanks for the quick reply there ODB.

I’ve included these lines in the .htaccess file.

Are these all that are required to enable rewrites as this isn’t something I’ve done before so a little confused?

RewriteEngine on
RewriteBase /magento/
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule .* index.php [L]

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top