Magento Forum

   
Page 1 of 2
Mysqli prepare error: Table ‘magento.core_config_field’ doesn’t exist
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

I am getting a database error during installation. I have mysql and PHP5 setup correctly. Using latest version of magento, also tried the SVN.

Zend_Db_Statement_Mysqli_Exception Object
(
[message:protected] => Mysqli prepare error: Table ‘magento.core_config_field’ doesn’t exist
[string:private] =>
[code:protected] => 0
[file:protected] => C:\Documents and Settings\[suer]\My Documents\Work\My Sites\default\site\web\magento\lib\Zend\Db\Statement\Mysqli.php
[line:protected] => 85
[trace:private] => Array
.....

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

I just tried to manually add an empty table to the database called “core_config_field” but then I get a similar error about cannot find a “path” column in the table. I am guessing this table is being accessed before it has been created in the system. There are two other tables which get created correctly in the database just before I get this error, “core_layout” and “core_resource”.

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

Does anybody have any ideas on this? This is the only reason I cannot install Magento, it simply wont get past this error. I have reinstalled PHP, with all the required addins. I have reconfigured Apache every way I know how but still not working. I have played with MySQL settings, permissions etc but this table still does not exist when it is accessed during installation.

One extra comment. I changed the settings in the magento config file to use pdo_mysql instead of mysqli on database creation, but I get similar error with that module.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@flubba86: when you start installing Magento your database is empty?

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 
Moshe - 24 October 2007 03:31 PM

@flubba86: when you start installing Magento your database is empty?

Yeah, I make sure to recreate an empty database every time I retry to install.

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

I just replaced my PHP5 details in Apache with some new Zend replacements, I load the relevant plugins into Zend (same as in PHP5) and now I have a different error…
[message:protected] => Mysqli prepare error: Table ‘magento.core_resource’ doesn’t exist, so now it isnt even getting as far as before :(.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Would you like to PM me your login info so i can check it out?

 
Magento Community Magento Community
Magento Community
Magento Community
 
winans_fred
Sr. Member
 
Total Posts:  83
Joined:  2007-09-06
 

We’re having basically the same problems, it’s not running the initial sql files to enable installation… does the database have to be empty?? I am getting the same error on a completely empty db as well.

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 
Moshe - 24 October 2007 06:04 PM

Would you like to PM me your login info so i can check it out?

I am running magento on a local server, so not able to give access sorry.

If it helps, I run Apache 2, Zend Core 2.5 (PHP5) and MySQL Server 5.1 and I am in a Win32 environment (shouldnt matter).

I think this is related to my other thread about “Not able to validate url: https://www.[server].com:443/magento" where it gets stuck trying to validate my HTTPS SSL settings (even though they are correct).

If I choose to validate my URL, only two tables get generated then I get the invalid URL error. If I choose to skip the validation, zero tables get generated and I get the table not found error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 
dsgnfred - 25 October 2007 10:55 AM

We’re having basically the same problems, it’s not running the initial sql files to enable installation… does the database have to be empty?? I am getting the same error on a completely empty db as well.

Do you have problems with the install validating your HTTPS url aswell?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Cacpro
Jr. Member
 
Total Posts:  3
Joined:  2007-10-31
 

I am having the exact same problems, has anyone found a solution yet?

 
Magento Community Magento Community
Magento Community
Magento Community
 
toxicshit
Jr. Member
 
Total Posts:  19
Joined:  2007-11-01
 

Im also having this problem as do some engineer in another company i know that i asked to test it (im an engineer at a hosting company) and have PHP5.2.4_1 mysql 5.1.22 installed on a freebsd6.2 server.

after answering installation the questions about the database user and pass i click next and get:

Zend_Db_Statement_Mysqli_Exception Object
(
[message:protected] => Mysqli prepare error: Table ‘magento.core_config_field’ doesn’t exist
[string:private] =>
[code:protected] => 0
[file:protected] => /usr/home/s/shadowcore/shadowcore.cname.web3.nl/public_html/shop/lib/Zend/Db/Statement/Mysqli.php
[line:protected] => 85
[trace:private] => Array
(
[0] => Array
................
.  ...........
.........
.......etc
.....etc

if i look at the contents of the database i only see 2 tables created :
core_layout
core_resource

Greetings Erwin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
toxicshit
Jr. Member
 
Total Posts:  19
Joined:  2007-11-01
 

Bump.

still having this problem asked some more guys on all kinds of hard and software. but they all have the same problem with this release of magento. can someone try to install it and report if he has the same problems.

Greetings Erwin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
winans_fred
Sr. Member
 
Total Posts:  83
Joined:  2007-09-06
 

Hi All

We managed to resolve these issues, and for us, it was resolved once we made sure to re-copy the app/etc files so they are completely fresh.  That doesn’t seem to make a lot of sense but hey, give it a try.  Oh yes, and we installed it to an existing database that had existing tables, so we know that works as well.  Good luck!

 
Magento Community Magento Community
Magento Community
Magento Community
 
toxicshit
Jr. Member
 
Total Posts:  19
Joined:  2007-11-01
 
dsgnfred - 06 November 2007 07:01 AM

Hi All

We managed to resolve these issues, and for us, it was resolved once we made sure to re-copy the app/etc files so they are completely fresh.  That doesn’t seem to make a lot of sense but hey, give it a try.  Oh yes, and we installed it to an existing database that had existing tables, so we know that works as well.  Good luck!

hello dsgnfred, from where did you re-copy the app/etc files ? and do you have a copy of a existing empty database for me ? or could you send me some files ( sql backup and the app/etc dir zipped / rarred ) ?

thanks in advance.

Greetings Erwin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hi guys,

Could you also try the solution described at http://www.magentocommerce.com/wiki/mediatemple_installation_guide_-_grid_service#known_issues ?

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 2