Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Internal Server 500
 
CSPalmisano
Member
 
Total Posts:  67
Joined:  2008-05-31
 

I’ve tried installing multiple times now and have made the requisite permissions adjustments. But I continue to get the Internal Server 500 error after entering my database information. Below is my error log info.

Any help is greatly appreciated.

[Fri Jul 04 08:57:01 2008] [error] [client 96.231.52.191] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use ‘RewriteOptions MaxRedirects’ to increase the limit if neccessary.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Post your .htaccess file for us. And if Magento is installed in a sub-directory, post the .htaccess file in the root directory so we can see what’s in it. Basically, you have something in your. htaccess file that’s causing an endless loop:

http://www.sitepoint.com/print/mod_rewrite-no-endless-loops/

 
Magento Community Magento Community
Magento Community
Magento Community
 
CSPalmisano
Member
 
Total Posts:  67
Joined:  2008-05-31
 

Magento IS installed in a subdirectory. Below are the two .htaccess files.

.htaccess in the root:

Action php-cgi /cgi-bin/php.cgi
AddHandler php
-cgi .phpx

.htaccess in the subdirectory where magento is installed.

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    
php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off
    
###########################################
# turn off compatibility with PHP4 when dealing with objects
    
    
php_flag zend.ze1_compatibility_mode Off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    #SetOutputFilter DEFLATE

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none
 
Magento Community Magento Community
Magento Community
Magento Community
 
ODB
Sr. Member
 
Avatar
Total Posts:  142
Joined:  2008-02-06
London
 

I think I got this because my host had configured the hosting package control panel to be http://magentoinstallation.com/admin, which is also the same as the magento backend admin.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CSPalmisano
Member
 
Total Posts:  67
Joined:  2008-05-31
 

Any help would be most appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
CSPalmisano
Member
 
Total Posts:  67
Joined:  2008-05-31
 

Anyone? please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
CSPalmisano
Member
 
Total Posts:  67
Joined:  2008-05-31
 

I could really use some help here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
fabianlopez
Jr. Member
 
Total Posts:  1
Joined:  2009-05-22
 

I solve the problem replacing this line:

#RewriteBase /magento

To this

RewriteBase /

 
Magento Community Magento Community
Magento Community
Magento Community
 
sdaugherty
Jr. Member
 
Total Posts:  18
Joined:  2009-03-13
Ohio
 

Thanks fabianlopez!  I made the same change to that line and it fixed my problem!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top