Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problems with installing php5 cgi workaround
 
lizord
Jr. Member
 
Total Posts:  1
Joined:  2008-06-30
 

Hello- please help!
i’m trying to install magento (on a php4 server) on my hosts server- i’m using valueweb-via costco wholesaleclub. I get an error when i try to access any php file. (ex:/magento/magento-check.php .)
also. i’m not too clear on how to edit the .htaccess file. the instructions tell me to update and add lines, but the example doesn’t look like it.
ERRORS:
Warning: Unexpected character in input: ‘’ (ASCII=15) state=1 in /nfs/cust/5/23/18/881325/cgi-bin/php5-cgi on line 131

Warning: Unexpected character in input: ‘ in /nfs/cust/5/23/18/881325/cgi-bin/php5-cgi on line 131

Warning: Unexpected character in input: ‘ in /nfs/cust/5/23/18/881325/cgi-bin/php5-cgi on line 131

Warning: Unexpected character in input: ‘ in /nfs/cust/5/23/18/881325/cgi-bin/php5-cgi on line 131

Parse error: syntax error, unexpected T_STRING in /nfs/cust/5/23/18/881325/cgi-bin/php5-cgi on line 131

my .htacess file info:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

Action php5-cgi /cgi-bin/php5-cgi
AddHandler php5-cgi .php

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

php_value memory_limit 64M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

# AddDefaultCharset Off
AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

THANK YOU!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Very Clever Stuff
Sr. Member
 
Avatar
Total Posts:  90
Joined:  2008-05-06
Sheffield, UK
 

Have you actually uploaded the php-cgi?

If not, download PHP, upload the file php-cgi to your /cgi-bin/ and CHMOD it to 755 (executable).

 
Magento Community Magento Community
Magento Community
Magento Community
 
ponkeymeat
Jr. Member
 
Total Posts:  1
Joined:  2008-11-20
 

If you’re using plesk make sure you put the php5-cgi file in a folder in the cgi-bin folder.  Don’t put the file alone in the cgi-bin folder.

Do something like this:

/cgi-bin/php/php5-cgi

Also make sure the file ownerships and permissions are correct for those using shell access.  FTP they should be correct already.

Hope this helps some folks.

I’m using RHEL 5 with Apache 2.2
PHP 5.1.6

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top