Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 3
Installation of a language pack
 
bas1968
Jr. Member
 
Avatar
Total Posts:  9
Joined:  2007-09-18
 

Hello, I have downloaded the dutch translation. Where do I need to install this language pack and how can I activate it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Hello bas1968,

To add the dutch translation just unzip the downloaded archive keeping the directory structure - you’ll get 2 new folders nl_NL under app/locale/ and nl_NL under app/design/frontend/default/default/.

Then go to admin System -> Configuration -> General tab -> Locale options, choose the locale there and click on ‘Save config’ button.

Please use the ‘Interface Locale’ drop-down in left bottom corner of the page to switch current locale in admin.

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FrenchMaster
Jr. Member
 
Total Posts:  4
Joined:  2007-10-15
 

Hello!

for those who get an error 500 message when swithing to german SHOP or French Shop after having installing a new language :

you must edit the htaccess file in your language directory (\de for german, \fr for french like follows :

#php_flag magic_quotes_gpc off
#php_flag short_open_tag on

DirectoryIndex index.php

RewriteBase /
RewriteRule !\.(js|ico|txt|gif|jpg|png|css)$ index.php

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{REQUEST_FILENAME} !-l

#RewriteRule .* index.php

It worked for me !

Installation on 1and1 provider.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ntis
Jr. Member
 
Total Posts:  18
Joined:  2007-10-08
 
Michael - 22 October 2007 05:31 AM

Hello bas1968,

To add the dutch translation just unzip the downloaded archive keeping the directory structure - you’ll get 2 new folders nl_NL under app/locale/ and nl_NL under app/design/frontend/default/default/.

Then go to admin System -> Configuration -> General tab -> Locale options, choose the locale there and click on ‘Save config’ button.

Please use the ‘Interface Locale’ drop-down in left bottom corner of the page to switch current locale in admin.

Thank you.

Hi,
Would also like to add our translation language package - Vietnamese- to Magento, but still did not work yet.
After unzip the package into the folder, I have the two new folders as your guideline above.

However, when going to admin and Locale option, our language is not displayed there.
Do I have to make any other modification/configuration to have Magento recognized the additional language?

Thank you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
ntis - 24 October 2007 12:55 AM

However, when going to admin and Locale option, our language is not displayed there.
Do I have to make any other modification/configuration to have Magento recognized the additional language?

Please open app/etc/config.xml and change vn_VN to vi_VN in line 58.

Thank you for reporting this issue. It will be fixed in the next release.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilipDac
Jr. Member
 
Total Posts:  17
Joined:  2007-09-08
 

Hi Michael,

I’ve followed your instruction to change line# 58 from “vn_VN” to “vi_VN” however the option for Vietnamese language still does not show in the Local options --> Language of the General tab. Do I need to do any other configuration?

Note: There are 2 directories named en_US and vn_VN in the ‘locale’ directory but there are 3 languages (German, English, French) showed in Local options --> Language. Is this normal?

Thanks,
Bacscar

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
bacscar - 24 October 2007 03:12 AM

I’ve followed your instruction to change line# 58 from “vn_VN” to “vi_VN” however the option for Vietnamese language still does not show in the Local options --> Language of the General tab. Do I need to do any other configuration?

What Magento version do you have ? Could you download and install the latest one (0.6.13160) ? Do you have ‘Vietnamese (Vietnam)’ option in ‘Interface Locale’ drop-down in left bottom corner of admin pages ?

bacscar - 24 October 2007 03:12 AM

There are 2 directories named en_US and vn_VN in the ‘locale’ directory

Please rename vn_VN directory to vi_VN.

 
Magento Community Magento Community
Magento Community
Magento Community
 
FrenchMaster
Jr. Member
 
Total Posts:  4
Joined:  2007-10-15
 

it’s the same for french: however ist installed, you CANNOT choose it in the left botom menu. French is not listed, only russian, german, english, etc.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
FrenchMaster - 24 October 2007 04:49 AM

it’s the same for french: however ist installed, you CANNOT choose it in the left botom menu. French is not listed, only russian, german, english, etc.

What Magento version do you use ? Is it a clean install or upgrade from previous versions ? Did you install a full installation package or a light one ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ntis
Jr. Member
 
Total Posts:  18
Joined:  2007-10-08
 

We are using 0.6.12840 here.
I tried to upgrade our Magento to the latest version, however, the Download for 0.6.13160 still link to 0.6.12840.tar.gz package. So we could not get the right package.

Please help double check it.
Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilipDac
Jr. Member
 
Total Posts:  17
Joined:  2007-09-08
 

Hi Michael,

My status is as below:

- Using 0.6.13160, installed from a Light installation zip file.
- Changed app/etc/config.xml line 58 from vn_VN to vi_VN; Changed 2 directories from vn_VN to vi_VN.
- ‘Interface locale’ combo box at bottom left corner of the screen showed Vietnamese language option
- Combo box ‘Language’ of General / Local options shows 4 options: the first option is blank, German, English, French. No Vietnamese language showed

Please check my screen shot as in attachment.

Thanks a lot,
Bacscar.

Image Attachments
20071025 VN lang not show.JPG
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Click “POST REPLY” button, in there you should have File Upload input box, screenshot definitely will help.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilipDac
Jr. Member
 
Total Posts:  17
Joined:  2007-09-08
 

@Moshe: thanks. I was able to upload the screen shot to my above post.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

bascar: could you please back up your database, drop it and recreate clean, so Magento can install a fresh structure on next reload?

The configuration options do not look like the new version, and i think this is the problem.

Please let me know if it works.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilipDac
Jr. Member
 
Total Posts:  17
Joined:  2007-09-08
 

Hi Moshe,

What I’ve done is:

- Drop the magento database and create it again. I used the collation: utf8_unicode_ci.
- Download the full installation file from http://www.magentocommerce.com/downloads/assets/0.6.13160/full/magento-0.6.13160.zip. (@Ntis: you can try the latest pack with this link)
- Changed app/etc/config.xml line 58 from vn_VN to vi_VN; Copy & change 2 directories from vn_VN to vi_VN in their location.
- Open localhost\Magento and follow the installation process.
- Set General \ Default country to Vietnam and Locale to Tieng Viet (Vietnam)
- Set Currency setup \ ‘Base currency’, ‘Display default currency’ and ‘Allowed currencies’ all to ‘dong’ (the Vietnamese currency). It displays fine in the front end.
- Set Locale Settings \ Allowed Currencies to ‘dong’

That is what i’ve done so far however the Vietnamese translation still do not display in the front end. I’m attaching here the screen shot of my General settings. Please let me know if you need to do anything else?

Thanks,
Bacscar.

Image Attachments
20071025 General settings top screen.PNG20071025 General settings bottom screen.PNG
 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Do you mind to PM me login info so i can take a look at the setup?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3