Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Url “https://www.[website].com:443/magento/” is invalid - version 0.6.13160
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

The following error appears during installation:
Url “https://www.[website].com:443/magento/” is invalid

I am using 1and1 hosting and I have a dedicated SSL certificate.

I cannot access “https://www.[website].com/magento/” but everything in the root folder like “https://www.[website].com/index.php” works just fine.

There is an .htaccess file in the root folder that specifies the following rewrite rules for https:

RewriteEngine On
RewriteCond 
%{SERVER_PORT} !^443$
RewriteRule ^(.*)$ https://www.[website].com/$1 [R]

There is also an .htaccess file under /magento/ that was changed as specified here so that Magento can work on 1and1.

I did not have this installation problem with previous versions of Magento.  When installing version 0.6.13160, I did not do an upgrade, I wiped the /magento/ folder clean to start over with a fresh installation.

Any ideas?

Thanks,
Catia

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

I have exactly the same issue. Using version 0.6.13160. On the second stage on installation it reports that the website Url “https://www.[website].com:443/magento/” is invalid. When you navigate to that directory under firefox, the browser reports an unending redirect condition and cannot display a resulting page. Navigating to any other directory on the server under SSL works correctly without issue, just problems with the /magento directory, obviously a bug in the redirecting of HTTPS addresses. Anybody else got any suggestions how to fix it? I bypassed this step by choosing HTTP and port 80 as my secure address, but then I get a database error, so no luck for me.

 
Magento Community Magento Community
Magento Community
Magento Community
 
YoavKutner
Guru
 
Avatar
Total Posts:  491
Joined:  2007-08-08
 

You should be able to check the ‘Skip URL validation’ check-box and it should work.

Please let me know if that works.

Thanks

yoav

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 
YoavKutner - 22 October 2007 04:08 PM

You should be able to check the ‘Skip URL validation’ check-box and it should work.

Please let me know if that works.

Thanks

yoav

Yes that works, but after that step I am still getting this error:
[message:protected] => Mysqli prepare error: Table ‘magento.core_config_field’ doesn’t exist
It is unrelated, so I have started a new thread for it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

I checked the “Skip URL validation” option, but on the following two steps of the installation, “Create Admin Account” and “You’re All Set!”, the pages lacked the usual CSS formatting.  I decided to ignore this and attempt to complete the installation.  I did not get any error messages, but something is not right because any Magento page I try to view is missing CSS formatting and images…

Do you know what the problem might be?

Thanks,
Catia

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@C: could you please run this statement and paste result? If you wish to keep it private you could send me PM.

select scopescope_idpathvalue from core_config_data where path like 'web/%';
Thanks
 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

Here are the results in CSV format.  I can’t tell if there are any problems here, but I did notice that “web/secure/protocol” is “http”, even though I left the default option of “https” during installation.  Was the setting changed because I checked “Skip URL validation”?

Please let me know if you need any other information that can help resolve the problem.

“default”;"0”;"web/url/media”;"/media/"
“default”;"0”;"web/url/js”;"/js/"
“default”;"0”;"web/url/skin”;"/skin/"
“default”;"0”;"web/url/upload”;"/media/upload/"
“default”;"0”;"web/default/no_route”;"cms/index/noRoute"
“default”;"0”;"web/default/front”;"cms"
“default”;"0”;"web/cookie/cookie_domain";
“default”;"0”;"web/cookie/cookie_path";
“stores”;"5”;"web/default/front”;"cms"
“stores”;"5”;"web/default/no_route”;"cms/index/noRoute"
“stores”;"5”;"web/url/js”;"/js/"
“stores”;"5”;"web/url/media”;"/media/"
“stores”;"5”;"web/url/skin”;"/skin/"
“stores”;"5”;"web/url/upload”;"/media/upload/"
“stores”;"5”;"web/unsecure/protocol”;"http"
“stores”;"5”;"web/unsecure/host”;"{{host}}"
“stores”;"5”;"web/unsecure/port”;"{{port}}"
“stores”;"5”;"web/unsecure/base_path”;"/de/"
“stores”;"5”;"web/secure/protocol”;"http"
“stores”;"5”;"web/secure/host”;"{{host}}"
“stores”;"5”;"web/secure/port”;"{{port}}"
“stores”;"5”;"web/secure/base_path”;"/de/"
“stores”;"5”;"web/cookie/cookie_domain";
“stores”;"5”;"web/cookie/cookie_path";
“stores”;"5”;"web/cookie/cookie_lifetime";
“stores”;"6”;"web/default/front”;"cms"
“stores”;"6”;"web/default/no_route”;"cms/index/noRoute"
“stores”;"6”;"web/url/js”;"/js/"
“stores”;"6”;"web/url/media”;"/media/"
“stores”;"6”;"web/url/skin”;"/skin/"

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

If that’s all you got, there’s definitely a problem…

During install wizard there are no errors? I mean exceptions, system php errors, etc.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

If I had seen any, I would have posted them wink
Like I said, after I checked the “Skip URL Validation” box, the installation seemed to go fine, except for the fact that the CSS formatting stopped appearing on all the pages.

Perhaps I should redo the installation and see if that does anything?
Or try to fix the original “https invalid” error so that I don’t have to check the “Skip URL Validation” box?

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

I am still having this same problem. I think this is the reason why my databases are not being generated for the next step of the install. If I try to validate the URL, I get his invalid error and if I try to skip the validation I get these table not found errors.

If it helps, I am running on a local server, with Apache 2, Zend Core 2.5 (PHP5) and MySQL Server 5.1 and I am in a Win32 environment (shouldnt matter).

 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

I “uninstalled” Magento by deleting all the files in the folder, and dropping all the tables in the database.  I then tried to install version 0.6.13160 a second time around, and encountered the same problems as I described earlier.  I had to check the “Skip URL validation” box (again), and the CSS formatting stopped working on all of the pages (again), but I was able to technically complete the installation without getting any error messages (again).

I ran the SQL command Moshe suggested and the results are slightly different from last time.  Here they are, except I replaced the actual domain name with “[website]”.

Any ideas to resolve this issue?

"default";"0";"web/url/media";"/media/"
"default"
;"0";"web/url/js";"/js/"
"default"
;"0";"web/url/skin";"/skin/"
"default"
;"0";"web/url/upload";"/media/upload/"
"default"
;"0";"web/default/no_route";"cms/index/noRoute"
"default"
;"0";"web/default/front";"cms"
"default"
;"0";"web/cookie/cookie_domain";
"default";"0";"web/cookie/cookie_path";
"stores";"1";"web/default/front";"cms"
"stores"
;"1";"web/default/no_route";"cms/index/noRoute"
"stores"
;"1";"web/url/js";"/js/"
"stores"
;"1";"web/url/media";"/media/"
"stores"
;"1";"web/url/skin";"/skin/"
"stores"
;"1";"web/url/upload";"/media/upload/"
"stores"
;"1";"web/unsecure/protocol";"http"
"stores"
;"1";"web/unsecure/host";"{{host}}"
"stores"
;"1";"web/unsecure/port";"{{port}}"
"stores"
;"1";"web/unsecure/base_path";"/"
"stores"
;"1";"web/secure/protocol";"http"
"stores"
;"1";"web/secure/host";"{{host}}"
"stores"
;"1";"web/secure/port";"{{port}}"
"stores"
;"1";"web/secure/base_path";"/"
"stores"
;"1";"web/cookie/cookie_domain";
"stores";"1";"web/cookie/cookie_path";
"stores";"1";"web/cookie/cookie_lifetime";
"default";"0";"web/cookie/cookie_lifetime";
"default";"0";"web/default/cms_home_page";"home"
"default"
;"0";"web/default/cms_no_route";"no-route"
"default"
;"0";"web/unsecure/host";"[website].com"
"default"
;"0";"web/unsecure/base_path";"/magento/"
"default"
;"0";"web/unsecure/protocol";"http"
"default"
;"0";"web/unsecure/port";"80"
"default"
;"0";"web/secure/host";"[website].com"
"default"
;"0";"web/secure/base_path";"/magento/"
"default"
;"0";"web/secure/protocol";"https"
"default"
;"0";"web/secure/port";"443"
 
Magento Community Magento Community
Magento Community
Magento Community
 
Catia
Jr. Member
 
Total Posts:  21
Joined:  2007-08-31
 

I am still having the same problem, but I haven’t had the time to fix it myself, not to mention I don’t even know where to start looking for the problem since there are no error messages!  rolleyes
Since there haven’t been any suggestions from the community, I guess I just have to wait for the next release that’s coming in a week or so.  I sure hope I won’t encounter the same problem with that version…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nox1
Jr. Member
 
Total Posts:  3
Joined:  2007-10-25
 
flubba86 - 22 October 2007 06:23 AM

I have exactly the same issue. Using version 0.6.13160. On the second stage on installation it reports that the website Url “https://www.[website].com:443/magento/” is invalid. When you navigate to that directory under firefox, the browser reports an unending redirect condition and cannot display a resulting page. Navigating to any other directory on the server under SSL works correctly without issue, just problems with the /magento directory, obviously a bug in the redirecting of HTTPS addresses. Anybody else got any suggestions how to fix it? I bypassed this step by choosing HTTP and port 80 as my secure address, but then I get a database error, so no luck for me.

Response: Still have the absolutly the same problem with magento-0.6.13160 by different provider
With out URL validation stil have the exception below, see details:

Zend_Db_Adapter_Mysqli_Exception Object
(
    
[_chainedException:protected] => 
    
[message:protected] => Level2:Commands out of syncyou can't run this command now
    [string:private] => 
    [code:protected] => 0
    [file:protected] => /var/www/vhosts/example.com/httpdocs/shop/lib/Varien/Db/Adapter/Mysqli.php
    [line:protected] => 127
    [trace:private] => Array
    ...

Install begin the full version in German
PHP 5.2.4 (in .htaccess “AddHandler php5-cgi .php")
MySQL - 4.1.11
Instalpath “example.com/shop/” with my own DB Name

After settings the first Setup (DB Entries and instalpath) have this error

Thanks for help

 
Magento Community Magento Community
Magento Community
Magento Community
 
MattJeans
Jr. Member
 
Total Posts:  1
Joined:  2007-11-13
 

Hi All
II have the same error (in that I get a load of code starting with Zend_Db_Adapter_Mysqli_Exception Object)

Firstly is there a magic bullet that I’ve missed on the forums to rectify this? Secondly, I’m struggling to achieve what others have, in that I haven’t managed to uninstall and start again. (I’ve deleted the Magento directory from the server and then dropped all of the tables within the database) but this doesn’t then allow the install wizard to run. It keeps coming back to:

Zend_Db_Adapter_Mysqli_Exception Object

Does anyone have any ideas on how I can sort out this problem.

Many Thanks
Matt

 
Magento Community Magento Community
Magento Community
Magento Community
 
Apoure
Jr. Member
 
Total Posts:  4
Joined:  2007-11-09
Australia
 

Hey guys i have this problem aswell but i modded my .htaccess file and i am not getting that error anymore of invalid etc....although when i click on login or go to checkout....it cannot find the folders magento/account/???

Where is this folder and how does it get generated??
This only happens on the https:// site not the http??

so what’s going on?? what is the correct .htaccess file etc...??

Cheers,
Apoure smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yossi M
Jr. Member
 
Total Posts:  5
Joined:  2008-01-17
Israel
 
YoavKutner - 22 October 2007 04:08 PM

You should be able to check the ‘Skip URL validation’ check-box and it should work.

Please let me know if that works.

Thanks

yoav

Hey yoav
i have the same thing

Url “http://62.219.17.132:80/~fastweb7/store/” is invalid

if i check the ‘Skip URL validation’ i cand log in into admin cos its not instalid right.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2