Magento Forum

   
Page 1 of 3
Internal Server Error
 
iPhony
Member
 
Avatar
Total Posts:  37
Joined:  2007-09-01
 

My current host is 1and1. I have uploaded the magento folder to my server but when I point to my domain the browser displays:

------
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
------

Nothing comes up, not even the installation page. So I looked through the forum and from some other topic I added the php5 modification to the .htaccess file in the main magento folder, and I created a php.ini file where I added the following:

----php.ini----
[PHP]
LoadModule rewrite_module modules/mod_rewrite.so
allow_url_fopen = on

----------------

But nothing changed. At this point I am not sure what to do. Could anyone please help?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mckooter
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2007-08-31
 

what type of 1and1 hosting do you have? im not sure the shared will work for magento, i dont think the mod rewrite is set correct

 
Magento Community Magento Community
Magento Community
Magento Community
 
iPhony
Member
 
Avatar
Total Posts:  37
Joined:  2007-09-01
 

I have a shared account with them.
What I do not understand is the following: if oscommerce and zencart work fine on a shared hosting plan, why wouldn’t magento. I understand magento is powerful but they need to also take into account the fact that most people use shared hosting. Maybe they should partner with hosting companies to have them set up their shared hosting plans for magento a bit like many are set up for blogging technologies for instance.

The changes I made didn’t do anything and I am still at square 0.
Any help would be greatly appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
pcox64
Jr. Member
 
Total Posts:  1
Joined:  2007-09-02
 

I had this problem but just worked out what the problem was.  I was missing the .htaccess file in the base directory - it was excluded when I moved the magento files into the web directory.  You may want to try checking the .htaccess file is present within the magento dir.

Cheers

Phil

 
Magento Community Magento Community
Magento Community
Magento Community
 
iPhony
Member
 
Avatar
Total Posts:  37
Joined:  2007-09-01
 

My .htaccess is actually there. I thought it was the problem and I added the php5 line but it still did not change anything.

Here is my .htaccess:

--------------------
php_flag magic_quotes_gpc off
php_flag short_open_tag on

DirectoryIndex index.php

RewriteEngine on

RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule .* index.php

AddType x-mapp-php5 .php
--------------------

 
Magento Community Magento Community
Magento Community
Magento Community
 
wolkenlos
Jr. Member
 
Total Posts:  5
Joined:  2007-09-02
 

same problem....

Installprozedure: http://www.mydomain.net/shop/install

Message:
“Internal Server Error”; I tried to change the .htacces file in the root directory - no effect

megento is installed in a subdirectory named “shop”
my settings:

PHP: 5.2.3
System Linux s30.server-centrum.de 2.6.22.2-42.fc6 #1 SMP Wed Aug 15 12:34:26 EDT 2007 i686
Build Date Jun 10 2007 23:35:06
Configure Command ‘./configure’ ‘--prefix=/usr/local/php5’ ‘--enable-force-cgi-redirect’ ‘--enable-safe-mode’ ‘--enable-magic-quotes’ ‘--with-openssl=/usr’ ‘--with-kerberos=/usr’ ‘--with-zlib=/usr’ ‘--enable-bcmath’ ‘--with-bz2=/usr’ ‘--enable-calendar’ ‘--with-curl=/usr’ ‘--enable-dba’ ‘--with-gdbm=/usr’ ‘--with-db4=/usr’ ‘--with-dbm=/usr’ ‘--with-cdb=/usr’ ‘--with-infile’ ‘--with-flatfile’ ‘--enable-dbase’ ‘--enable-dbx’ ‘--enable-exif’ ‘--enable-ftp’ ‘--with-gd=/usr’ ‘--enable-gd-native-ttf’ ‘--with-gettext=/usr’ ‘--with-gmp=/usr’ ‘--with-imap=/usr’ ‘--with-imap-ssl=/usr’ ‘--with-ldap=/usr’ ‘--enable-mbstring’ ‘--with-mcrypt=/usr’ ‘--with-mhash=/usr’ ‘--with-mime-magic’ ‘--with-mysql=/usr’ ‘--with-mysqli=/usr/bin/mysql_config’ ‘--with-unixODBC=/usr’ ‘--with-pgsql=/usr’ ‘--with-pspell=/usr’ ‘--with-mm=/usr’ ‘--with-snmp=/usr’ ‘--enable-ucd-snmp-hack’ ‘--enable-shmop’ ‘--enable-soap’ ‘--enable-sockets’ ‘--enable-sysvmsg’ ‘--enable-sysvsem’ ‘--enable-sysvshm’ ‘--with-tidy=/usr’ ‘--enable-wddx’ ‘--with-xsl=/usr’ ‘--enable-memory-limit’ ‘--with-freetype-dir=/usr’ ‘--with-jpeg-dir=/usr’ ‘--with-openssl-dir=/usr’ ‘--with-png-dir=/usr’ ‘--with-zlib-dir=/usr’
Server API CGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /usr/local/php5/lib
Loaded Configuration File /usr/local/Zend_php5/etc/php.ini
PHP API 20041225
PHP Extension 20060613
Zend Extension 220060519
Debug Build no
Thread Safety disabled
Zend Memory Manager enabled
IPv6 Support enabled
Registered PHP Streams php, file, data, http, ftp, compress.bzip2, compress.zlib, https, ftps
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, convert.iconv.*, bzip2.*, zlib.*

please help!
regards
wolkenlos

 
Magento Community Magento Community
Magento Community
Magento Community
 
mckooter
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2007-08-31
 
iPhony - 02 September 2007 06:14 AM

I have a shared account with them.
What I do not understand is the following: if oscommerce and zencart work fine on a shared hosting plan, why wouldn’t magento.

the requirements http://www.magentocommerce.com/system-requirements are much more strict than you would find with oscommerce and zencart, I understand your frusteration with the process, I have 1and1 shared hosting that i use mainly, i havent even tried it there, but i assume i will run into the same problems, mainly we cannot make the required edits nessisary on our own as its a shared solution. the zend framework itself is too restrictive i think, (not sure on that) if it is the zen framework itll be much easier to eventually convince shared companies like 1and1 to make the adjustments nessisary as it could easily become a standard.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jaromie
Jr. Member
 
Total Posts:  3
Joined:  2007-09-03
 
mckooter - 02 September 2007 05:48 PM

the requirements http://www.magentocommerce.com/system-requirements are much more strict than you would find with oscommerce and zencart,

I have a shared hosting meeting every requirement listed on that page (by the way, URL rewrite capabilities aren’t required, as per that page; but I do have those too), and I do have a HTTP 500 error with Magento.

Trying to work around it, figure it what’s the problem. I’m a little confounded by the 50MB or so of the beta package though....

 
Magento Community Magento Community
Magento Community
Magento Community
 
wolkenlos
Jr. Member
 
Total Posts:  5
Joined:  2007-09-02
 

hello!

same problems (like newbie) with the internal server error; required settings are ok…
if someone have any idea please post a solution grin

greetings
wolkenlos

 
Magento Community Magento Community
Magento Community
Magento Community
 
misterniall
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2007-09-03
Montreal
 

I may be the same issue encountered on Site5. If possible replacing the php_flag options in the .htaccess with a custom php.ini file might solve the problem.  try commenting out the php_flag options and see if the error stops.  If so then this link may help you.

http://tips-scripts.com/php_ini

It has worked fine on Site5 and if you have acces to the actual logs you will save a lot of time since a 500 error is really not that helpful. There are also a number of threads on this topic.

N.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wolkenlos
Jr. Member
 
Total Posts:  5
Joined:  2007-09-02
 

well… I cant believe… the internal server error is fixed (play around with the .htaccess)
hmm.. new problems…

PHP Extension “pdo_mysql” must be loaded

well I checked my php.ini file:
settings pdo:

PDO
PDO support enabled
PDO drivers sqlite2, sqlite
pdo_sqlite
PDO Driver for SQLite 3.x enabled
PECL Module version (bundled) 1.0.1 $Id: pdo_sqlite.c,v 1.10.2.6.2.2 2007/03/23 14:30:00 wez Exp $
SQLite Library 3.3.17

well… are the sqlite drivers not enough? please one more help grin

merci
wolkenlos

 
Magento Community Magento Community
Magento Community
Magento Community
 
mckooter
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2007-08-31
 

you should fine a line as follows:

;extension=php_pdo_mysql.dll

need to remove the ;

as for everyone above, if your using a shared windows hosting you might run into problems as this beta is very picky on windows systems

 
Magento Community Magento Community
Magento Community
Magento Community
 
iPhony
Member
 
Avatar
Total Posts:  37
Joined:  2007-09-01
 

Guys let’s be a little serious here. This problem is not fixed. At least not for me. And I do not know anyone who has confirmed solving this issue. Who flagged this as fixed?

I contacted 1and1 and here are a couple of links they sent me.

The links below contain information about the version of software and
application that’s running in their server.

http://links.1and1faqs.com/check_info.php5s

http://faq.1and1.com/miscellaneous/13.html

I tried the site5 suggestion but not only it wasn’t very clear but also it did not do anything. Anyone else has any suggestion to get magento working on 1and1?

 
Magento Community Magento Community
Magento Community
Magento Community
 
wolkenlos
Jr. Member
 
Total Posts:  5
Joined:  2007-09-02
 

hello mckooter!

you wrote:
you should fine a line as follows:

;extension=php_pdo_mysql.dll

fine - were is this statement to remove? I tried to install the system on a shared linux server.

thanks for help!

greetings
wolkenlos

 
Magento Community Magento Community
Magento Community
Magento Community
 
simplymarco
Jr. Member
 
Total Posts:  8
Joined:  2007-10-02
 
iPhony - 04 September 2007 05:38 PM

Guys let’s be a little serious here. This problem is not fixed. At least not for me. And I do not know anyone who has confirmed solving this issue. Who flagged this as fixed?

I contacted 1and1 and here are a couple of links they sent me.

The links below contain information about the version of software and
application that’s running in their server.

http://links.1and1faqs.com/check_info.php5s

http://faq.1and1.com/miscellaneous/13.html


I tried the site5 suggestion but not only it wasn’t very clear but also it did not do anything. Anyone else has any suggestion to get magento working on 1and1?

@iPhony —Like you, I too confirmed that all the PHP5 and other system requirements are met by 1and1.  I followed the install guide with a high level of attention to the details, ran the chmod’s over ssh, etc, but that didn’t make anything work. 

I just got off the phone with the helpful folks at 1and1 and I was informed that just the first line in the magento/.htaccess file “php_flag magic_quotes_gpc off” would require their managed hosting package.  That’s quite a monthly cost increase for me from the shared hosting account I currently have, but at least they have 50% off for the first 3 months.

I am cautious about altering the magento system just so it can run on a shared hosting account.  Maybe I’m being paranoid, but I’d like to let the magento team take advantage of the code that they’re laying down.  It’s a forward-looking philosophy, I suppose. 

Until the Magento team makes the system a decision to address shared hosting, if I want to stick with 1and1, managed hosting maybe the way to go, unfortunately.  Can anyone set me straight if this is wrong?

Thanks and much respect!

-Marco

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@simplymarco: The last released version already can manage without “php_flag magic_quotes_gpc off” line.
Please try running Magento without this line.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 3