Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

[Resolvido] "links" não funcionam…
 
LuizPortella
Jr. Member
 
Total Posts:  9
Joined:  2008-06-25
 

Olá pessoal, já postei isso em outro lugar mas o pessoal não respondeu.

Todos os “links” em http://localhost/~dijz/magento/index.php/ não funcionam. eu recebo algo como
http://localhost/~dijz/magento/about-magento-demo-store e não
http://localhost/~dijz/magento/index.php/about-magento-demo-store

Eu posso arrumar isso em Admin >> System >> Configuration >> Web >> Unsecure >> Base Link URL
{{unsecure_base_url}} deve passar a ser {{unsecure_base_url}}index.php/
mas arrumado isso a administração vai para o pau e passa a ter atalhos como

http://localhost/~dijz/magento/index.php/index.php/admin/system_config/edit/section/web/
veja “index.php/index.php/"…então eu mudei de volta pelo phpmyadmin.

A loja Magento não viu isso, não soube da mudaça facilmente, depois de um bom tempo ela descobriu a mudança.
Como posso arrumar esse problema?

Em Admin >> CMS >> Manage Pages >> Identifier
Mudei “about-magento-demo-store” para “quem-somos” Mas a loja ignora… :(
Como faço para essa mudança funcionar de vez?

Obrigado!

Meus dados:
Apache/2.2.9 (Debian) PHP/5.2.6-1 with Suhosin-Patch Server at localhost Port 80

htaccess
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

## DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

## php_value memory_limit 64M
## php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

## php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

## php_flag suhosin.session.cryptua off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

## SecFilterEngine Off
## SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary
</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

## SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

## Options +FollowSymLinks
## RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

RewriteBase /magento/index.php

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
 
LuizPortella
Jr. Member
 
Total Posts:  9
Joined:  2008-06-25
 

Olá,

Eu encontrei http://www.magentocommerce.com/boards/viewthread/8699/P30/ veja mensagem do
Moshe

Go to Admin > System > Configuration > Web > Search Engines Optimization

Set “Use Web Server Rewrites” to “No”

Go to System > Cache management, set “All Cache” to “Refresh” and click Save.

-----

Agora os “links” funcionam na loja!!!

O Identifier e o Title do “About Us” foram mudados.
Mas o Magento não captou a mudança “about-magento-demo-store” foi para “quem-somos” e “About Us” >> “Quem somos”

Então eu apagei a página, usei o “Refresh” e nada mudou… I ainda tenho About Us com o atalho
http://localhost/~dijz/magento/index.php/about-magento-demo-store
Como posso trabalhar direito com o CMS???

Obrigado!

 
Magento Community Magento Community
Magento Community
Magento Community
 
LuizPortella
Jr. Member
 
Total Posts:  9
Joined:  2008-06-25
 

Eu li http://www.magentocommerce.com/boards/viewthread/7327/ e descobri como arrumar isso.

Admin >> CMS >> Static Blocks >> “Title = Footer Links; Identifier = footer_links” >> Edit
Agora eu tenho “Quem Somos”

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top