Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

links don’t works [ FIXED!!! ]
 
LuizPortella
Jr. Member
 
Total Posts:  9
Joined:  2008-06-25
 

Hi,

All links at http://localhost/~dijz/magento/index.php/ don’t works. I get
http://localhost/~dijz/magento/about-magento-demo-store and not
http://localhost/~dijz/magento/index.php/about-magento-demo-store

I can fix it at Admin >> System >> Configuration >> Web >> Unsecure >> Base Link URL
{{unsecure_base_url}} go to {{unsecure_base_url}}index.php/ but then Admin don’t works and I get urls like

http://localhost/~dijz/magento/index.php/index.php/admin/system_config/edit/section/web/
see “index.php/index.php/"… I change it back by phpmyadmin.

the site Magento don’t look, don’t know about the change easy, after many minutes it get the change.
How I cant fix it? All links at Frontend don’t works…

At Admin >> CMS >> Manage Pages >> Identifier
I change “about-magento-demo-store” to “quem-somos” but the site never know about it… :(
How make these changes wokrs?

My system:
Apache/2.2.9 (Debian) PHP/5.2.6-1 with Suhosin-Patch Server at localhost Port 80

My .htaccess
############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

## DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

## php_value memory_limit 64M
## php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

## php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

#php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

## php_flag suhosin.session.cryptua off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

## SecFilterEngine Off
## SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter
#SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
#BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
#BrowserMatch ^Mozilla/4\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
#BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
# Don’t compress images
#SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don’t deliver the wrong content
#Header append Vary User-Agent env=!dont-vary
</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

## SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

## Options +FollowSymLinks
## RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

RewriteBase /magento/index.php

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault “access plus 1 year”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
 
LuizPortella
Jr. Member
 
Total Posts:  9
Joined:  2008-06-25
 

Olá,

I found http://www.magentocommerce.com/boards/viewthread/8699/P30/ by
Moshe

Go to Admin > System > Configuration > Web > Search Engines Optimization

Set “Use Web Server Rewrites” to “No”

Go to System > Cache management, set “All Cache” to “Refresh” and click Save.

-----

The likns works now!!!

The Identifier and the Title for About Us I have changed.
But Magento don’t know “about-magento-demo-store” change to “quem-somos” and “About Us” >> “Quem somos”

Then I deleted this page, I used “Refresh” and nothing change… I have About Us with the link
http://localhost/~dijz/magento/index.php/about-magento-demo-store
How I can fine work with CMS???

Thanks a lot

 
Magento Community Magento Community
Magento Community
Magento Community
 
jenks
Member
 
Total Posts:  37
Joined:  2008-06-03
Michigan
 

Are you using cache management? If so or unsure go to SYSTEM -> Cache Management and check… if there are any check boxes that means you are and that is likely the culprit. Choose refresh from the drop down and and then click SAVE Cache settings at the top.

I would try this anyways. The only other thing I could think is that it’s hard coded somewhere but I don’t think that’s the issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LuizPortella
Jr. Member
 
Total Posts:  9
Joined:  2008-06-25
 

Thanks, Jenks

I read http://www.magentocommerce.com/boards/viewthread/7327/ and find how to fix it.

Admin >> CMS >> Static Blocks >> “Title = Footer Links; Identifier = footer_links” >> Edit
Now I get “Quem Somos”

 
Magento Community Magento Community
Magento Community
Magento Community
 
jenks
Member
 
Total Posts:  37
Joined:  2008-06-03
Michigan
 

Cool. I’m just trying to get my support game up as I see a big lack of help beyond some of the simple things.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top