Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
The requested URL /install/ was not found on this server. 
 
chipmunk
Jr. Member
 
Total Posts:  3
Joined:  2007-10-22
 
Moshe - 18 October 2007 05:56 PM

And here’s your problem - blank .htaccess in root.

put this in there:

<IfModule mod_php5.c>
    
php_flag magic_quotes_gpc off
    php_flag short_open_tag on
</IfModule>

DirectoryIndex index.php

RewriteEngine on

RewriteCond 
%{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond 
%{REQUEST_FILENAME} !-d
RewriteCond 
%{REQUEST_FILENAME} !-l

RewriteRule 
.* index.php

I have set the .htaccess file in the root directory and when i point to the root directory something wrongs happens!

This is what i get at the top of the page:

Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /misc/34/000/126/515/1/user/web/rockookoo.com/store/app/code/core/Mage/Install/controllers/WizardController.php on line 20
[0] in set_time_limit(120) in /misc/34/000/126/515/1/user/web/rockookoo.com/store/app/code/core/Mage/Install/controllers/WizardController.php on line 20
[1] in include("/misc/34/000/126/515/1/user/web/rockookoo.com/store/app/code/core/Mage/Install/controllers/WizardCon") in /misc/34/000/126/515/1/user/web/rockookoo.com/store/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php on line 122
[2] in Mage_Core_Controller_Varien_Router_Standard->match(Zend_Controller_Request_Http) in /misc/34/000/126/515/1/user/web/rockookoo.com/store/app/code/core/Mage/Core/Controller/Varien/Front.php on line 164
[3] in Mage_Core_Controller_Varien_Front->dispatch() in /misc/34/000/126/515/1/user/web/rockookoo.com/store/app/Mage.php on line 378
[4] in Mage::run("base") in /misc/34/000/126/515/1/user/web/rockookoo.com/store/index.php on line 28

What should i do to continue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
micyaro
Jr. Member
 
Total Posts:  2
Joined:  2007-09-04
 

Hi,

I am having the same error with my installation, although the .htaccess is in the root of the magento dir with the proper content… Has anybody a solution for it? smile

Regards,
Mike

 
Magento Community Magento Community
Magento Community
Magento Community
 
vcube
Jr. Member
 
Total Posts:  3
Joined:  2007-10-22
France
 

I am facing a similar problem when trying to install Magento : HTTP 404 error.

The .htaccess seems ok, and I know it is working : first, I got an error because of PHP version, and I had to add this line in my .htaccess file :
AddType x-mapp-php5 .php

Since I did, I could get a little further : I am redirected to xxx.com/install and I get the 404 error.

I believe this proves that .htaccess are enabled.

I have read in the “Getting started” comments this could be solved by editing httpd.conf. Unfortunately, my web hoster won’t let me.

Is there any workaround I could try?

Thx

 
Magento Community Magento Community
Magento Community
Magento Community
 
flubba86
Jr. Member
 
Total Posts:  11
Joined:  2007-10-22
 

This is a very common error faced my all on installation.

The short answer is to edit your httpd.conf Apache file and change:
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

Change AllowOveride to All.

The longer answer, and more proper procedure is to leave the default settings as they are and add an additional setting like thus:
<Directory “[path-to-website]/magento">
AllowOverride All
</Directory>
This explicitly sets this directory to allow overrides and then it will be all good.

 
Magento Community Magento Community
Magento Community
Magento Community
 
vcube
Jr. Member
 
Total Posts:  3
Joined:  2007-10-22
France
 

Thanks but my problem is I don’t have access to httpd.conf : I’m trying to install Magento on a distant server, and my hoster doesn’t allow me to change Apache settings.

I suppose there is no way I could install Magento. Too bad : it seemed to match perfectly my needs…

Thanks anyway.

 
Magento Community Magento Community
Magento Community
Magento Community
 
micyaro
Jr. Member
 
Total Posts:  2
Joined:  2007-09-04
 

It is not just the .htaccess file… you have to be sure mod_rewrite is enabled on the server.

On ubuntu 7x you have to enable the mod_rewrite this way:
run

/etc/init.d/apache2 force-reload to enable
 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
chipmunk - 22 October 2007 11:10 PM

This is what i get at the top of the page:

Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /misc/34/000/126/515/1/user/web/rockookoo.com/store/app/code/core/Mage/Install/controllers/WizardController.php on line 20
...
What should i do to continue?

I guess your hoster doesn’t allow you to use set_time_limit function. You can try to comment out that line.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michael_1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
vcube - 22 October 2007 11:27 PM

I have read in the “Getting started” comments this could be solved by editing httpd.conf. Unfortunately, my web hoster won’t let me.
Is there any workaround I could try?

Could you ask your hoster just to enable mod_rewrite ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@chipmunk: Magento is not and will not be compatible with safe_mode, some of the reasons outlined here:
http://www.php.net/&#x7E;derick/meeting-notes.html#id14

As safe_mode setting is PHP_INI_SYSTEM and can not be changed by .htaccess, your choice would be to ask your host to change this for you, switch the host to more accommodating one or use PHP-CGI solution:
http://www.magentocommerce.com/knowledge-base/entry/installing-magento-on-a-php4-server

 
Magento Community Magento Community
Magento Community
Magento Community
 
vcube
Jr. Member
 
Total Posts:  3
Joined:  2007-10-22
France
 

I found the answer : I just had to uncomment this line in the root .htaccess:
Rewrite base /

Don’t ask me why it was commented: I have no idea!

Anyway, I get a nice install screen… smile

Thanks everyone!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Octopus Inc
Jr. Member
 
Total Posts:  3
Joined:  2007-10-06
 

If you are using virtual hosts (e.g. a /extra/httpd-vhosts.conf file) you need to add the line
AllowOverride All
to that file’s directory listing for your site instead of the main httpd.conf file.

Worked for me!!!!!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
thyon
Jr. Member
 
Avatar
Total Posts:  1
Joined:  2007-10-20
 

AND REMEMBER

change your default rewrite BASE, if you didn’t install in your server ROOT. OOPS, this one will fix MOST problems.

#RewriteBase /
RewriteBase /~admin/magento

Happy Installation....

 
Magento Community Magento Community
Magento Community
Magento Community
 
vectran
Jr. Member
 
Avatar
Total Posts:  7
Joined:  2007-11-28
 

Thanks Moshe for your help about the .htaccess files, they appeared hidden at first in my FTP program (Coda) it’s all happily installing now. YAY!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2