Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t Install Magento on LEMP dedicated server, Need help, Urgent! 
 
MindOverMatter
Jr. Member
 
Total Posts:  2
Joined:  2014-04-10
 

I’m currently running the latest LEMP stack, (ubuntu Server, Nginx, Mysql, PHP) on a dedicated server all managed by me.

All newly installed LEMP stack components as of June 1st 2014.

When I followed this guide:
http://www.howtoforge.com/running-magento-1.6.0.0-on-nginx-lemp-on-debian-squeeze-ubuntu-11.04
to install magento. I did everything it said in the guide, but when I access the mypublicdomain.com/magento it either gives me 502 bad gateway error or when I access it directly by connecting to the network through the router, (direct connect) it just says welcome to nginx and does not show the Magento installer.

Then I also looked at this guide:
http://www.magentocommerce.com/knowledge-base/entry/ce18-and-ee113-installing
and set appropriate file permissions for dedicated server and it still didn’t work.

Can someone please tell me what I’m doing wrong, I need magneto installed, but I feel like I tried everything and I do not know what else to try.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Veio
Jr. Member
 
Total Posts:  2
Joined:  2013-09-13
 

Check in nginx vhost settings, you need to add /magento/ in “location” paths, p.e.:

location /app/ -> location /magento/app/

add in all paths

or copy the magento folder to the website’s root

 
Magento Community Magento Community
Magento Community
Magento Community
 
MindOverMatter
Jr. Member
 
Total Posts:  2
Joined:  2014-04-10
 
Veio - 06 June 2014 03:19 PM

Check in nginx vhost settings, you need to add /magento/ in “location” paths, p.e.:

location /app/ -> location /magento/app/

add in all paths

or copy the magento folder to the website’s root

I’m confused in which vhost settings to check this and where to put this in, can you be more specific?

I looked at the “/etc/nginx/sites-available/www.sitedomain.com.vhost” file and also at the “/etc/nginx/sites-available/default” file and couldn’t find where to properly insert this.

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1093
Joined:  2008-07-16
London, United Kingdom
 

Hey,

So you have nginx running, what about the php-fpm service?
What about ownership of the files/folders?

Have you setup a server before? If your struggling, why not get some pro’s to do it for you

Im not affiliated with these guys, but this may be an option
https://www.magenx.com/

They do a installation service option. Which might save you the hassel

brendan

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top