Magento Forum

   
Custom module block ist not shown
 
sebastianm
Jr. Member
 
Total Posts:  1
Joined:  2008-06-23
 

Hi,

I added a new module to app/code/local.

Everything works fine (controller display, etc) except for displaying this modules block in catalogsearch result.

I added

<reference name="content">
<
block type="carsearch/list" name="cs" template="carsearch/list.phtml">  </block>

  <
block type="catalogsearch/result" name="search.result" template="catalogsearch/result.phtml">
                <
action method="initList"><template>catalog/product/list.phtml</template></action>
            </
block>
        </
reference>

to catalogsearch.xml.

The block file itself is called, when adding a debug message to dm_CarSearch_Block_List.php it is displayed.

But the template is not displayed. Also the new block is missing in profiling list.

What is wrong?
What do I have to keep in mind when adding csutom modules / blocks?

Thank you,
Sebastian

 
Magento Community Magento Community
Magento Community
Magento Community
 
Bojan Hrnkas
Member
 
Total Posts:  51
Joined:  2008-04-15
 

I also have the problem with displaying custom block. If I substitute it with core/template block in my layout, then I get some output, but with mymodule/mymodule block it shows only empty magento page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
thungk
Jr. Member
 
Total Posts:  20
Joined:  2009-06-10
 

I am having this problem, too.  Were either of you able to solve this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
thungk
Jr. Member
 
Total Posts:  20
Joined:  2009-06-10
 

Nevermind..the cause of my problem was very silly--I had the module disabled in my magento configuration rasberry

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top