Magento Forum

secure site breaks my checkout : /
 
julian5000
Jr. Member
 
Total Posts:  13
Joined:  2008-05-06
 

hello all. i’ve looked but i can’t seem to find an answer to this problem.

when i turn on secure urls for the front end my checkout breaks. clicking on ‘Checkout’ produces this error:

“Not Found. The requested URL /checkout/onepage/ was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

i have set my base URL to “https://secure.australiankaraokesystems.com.au/”, is this all i have to do? when i looked on my server the folder for the secure url is empty, does magento or my server somehow serve up the files from the non-secure url’s folder? or do i need to put some files in the secure one?

i tried mirroring the non-secure url on the secure one, but that didn’t work either.

cheers for the help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
julian5000
Jr. Member
 
Total Posts:  13
Joined:  2008-05-06
 

edit

 
Magento Community Magento Community
Magento Community
Magento Community
 
harakiry
Jr. Member
 
Total Posts:  27
Joined:  2008-06-23
 

Have you contacted your host’s tech staff?

 
Magento Community Magento Community
Magento Community
Magento Community
 
psylvia
Jr. Member
 
Total Posts:  6
Joined:  2008-11-07
Orlando, Florida - USA
 

I am having the same issue and have found that the problem is related to either cookies or session variables.  Not sure which one yet.  You will most likely find that you can make the problem go away by doing the following.  This will not resolve the issue, just help to better identify the problem.

Got to:  SYSTEM --> CONFIGURATION --> WEB

If you change the URL of the Secure and also the Unsecure to match (http and http) or (https and https) It will most likely start working. (SEE ATTACHMENT)

I realize that this is not the resolution that we are looking for but this is what I have determined where the issue lies.

I have tried clearing caches, disabling caching and everything else under the sun and this is the only thing that has worked so far.  It is a session variable issue that is not passed from the unsecure cookie to the secure cookie I believe - could be wrong here. I don’t yet have a clear understanding of how this part is being implemented.

Maybe someone can elaborate and fill in the blank for us.

If I had hair, I would have pulled it all out by now :o) Lucky for me.

Image Attachments
secure_unsecure.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
PhilBey
Jr. Member
 
Total Posts:  2
Joined:  2009-01-10
 

I have the same problem - did you figure out what caused the problem or a fix?  Seems like a server setting of some sort, but bit beyond me to figure out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JMJ Development
Member
 
Avatar
Total Posts:  40
Joined:  2008-08-07
Australia
 

Hi,

I had the same issue. I noticed that all was well if I put “index.php/” in the url before “checkout/” so it looked like “...com/index.php/checkout/”.

As i am using a virtual host and have my url rewrites in the httpd.conf file, to try improve the speed of Magento, I simply add the below to etc/httpd/conf.d/ssl.conf <virtual host> section and restarted Apache.

<IfModule mod_rewrite.c>
  
  
RewriteEngine on
  RewriteBase 
/
  
RewriteRule .* index.php [L]

</IfModule>

Now i dont have to include “index.php/” in my secure urls and everything works seamlessly

I hope this helps.

Kind Regards,

Jack

 
Magento Community Magento Community
Magento Community
Magento Community
 
xildatin
Jr. Member
 
Total Posts:  2
Joined:  2010-03-30
 

By default Apache is set to listen to all IP addresses on port 80.  If you simply modify the default httpd-ssl.conf file (in my case apache22/extra/httpd-ssl.conf) when installing a certificate then it will listen to all IP addresses on port 443 as well.  This error may occur because the server is trying to find checkout/onepage in the server’s default website’s document folder.

The resolution is to define a VirtualHost that listens to port 443 for the IP address/url associated with the web site that you are defining.

Using FreeBSD 8.1 and Apache 2.2

Listen 192.168.1.1
Listen 192.168.1.1
:443

<VirtualHost 192.168.1.1:80>
    
ServerName 192.168.1.1
    ServerAdmin foo
@bar.com
    DocumentRoot 
"/usr/local/www/magento/data"
    
ErrorLog "/usr/local/www/magento/logs/error.log"
    
CustomLog "/usr/local/www/magento/logs/access.log" common
    ScriptAlias 
/cgi-bin"/usr/local/www/magento/cgi-bin/"

    
<Directory "/usr/local/www/magento/data">
        
DirectoryIndex index.php
        Options 
-Indexes FollowSymLinks +ExecCGI
        AllowOverride All 
        AddHandler php5
-fastcgi .php
        Action php5
-fastcgi /cgi-bin/php.cgi
        Order allow
,deny
        Allow from all
    
</Directory>

    <
Directory "/usr/local/www/magento/cgi-bin">
        
AllowOverride None
        Options None
        Order allow
,deny
        Allow from all
    
</Directory>

</
VirtualHost>

<
VirtualHost 192.168.2.40:443>
    
ServerName 192.168.1.1:443
    ServerAdmin foo
@bar.com
    DocumentRoot 
"/usr/local/www/magento/data"
    
ErrorLog "/usr/local/www/magento/logs/error.log"
    
CustomLog "/usr/local/www/magento/logs/access.log" common
    ScriptAlias 
/cgi-bin"/usr/local/www/magento/cgi-bin/"
    
SSLCertificateKeyFile "/usr/local/etc/apache22/ssl.key/server.key"
    
SSLCertificateFile "/usr/local/etc/apache22/ssl.crt/server.crt"

    
<Directory "/usr/local/www/magento/data">
        
DirectoryIndex index.php
        Options 
-Indexes FollowSymLinks +ExecCGI
        AllowOverride All 
        AddHandler php5
-fastcgi .php
        Action php5
-fastcgi /cgi-bin/php.cgi
        Order allow
,deny
        Allow from all
    
</Directory>

    <
Directory "/usr/local/www/magento/cgi-bin">
        
AllowOverride None
        Options None
        Order allow
,deny
        Allow from all
    
</Directory>

</
VirtualHost>
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top