Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Attention required: order notification failing
 
l0st
Member
 
Total Posts:  55
Joined:  2008-04-06
 

Hello *,

We’ve made several unsuccessful attempts to send order notifications to your notification callback URL, https://domain.com/index.php/googlecheckout/api.index.php As a result, you aren’t receiving order status, risk, or other notifications.

To help you identify the issue with your callback URL, please review the errors we encountered while sending notifications to you. To review this error information:

1. Sign in to Google Checkout.
2. Click on the Tools tab.
3. Click Integration Console.

Error messages will appear under ‘Integration Issues.’ If necessary, you can also update your callback URL in the ‘API callback URL’ box on the same page.

For more information about receiving notifications via the notification API, visit http://code.google.com/apis/checkout/developer/index.html#notification.

URL you are using for merchant calculations is not valid or is not https http://www.sdfta.com/googlecheckout/api/—the error we got is: An HTTPS URL is required.

And I just realized that because of this error I missed out on 34 transactions! That’s major money. Now--- I do have ssl installed and correctly. How do I fix this error? Also changed the {{base_url}} for unsecure and secure.

Also I get this error as well:
{{base_url}} is not recommended to use in a production environment to declare the Base Unsecure Url / Base Secure Url. It is highly recommended to change this value in you Magento configuration.

Please help me.!

 
Magento Community Magento Community
Magento Community
Magento Community
 
l0st
Member
 
Total Posts:  55
Joined:  2008-04-06
 

http://www.sdfta.com uses an invalid security certificate.

The certificate is only valid for sdfta.com

(Error code: ssl_error_bad_cert_domain)

What the heck? Why is this? when I go to https://sdfta.com/ my ssl works fine. Can this be the cause of my checkout problems with google checkout and paypal pro?

 
Magento Community Magento Community
Magento Community
Magento Community
 
l0st
Member
 
Total Posts:  55
Joined:  2008-04-06
 

I’m still in the same shoe that I was before.

 
Magento Community Magento Community
Magento Community
Magento Community
 
l0st
Member
 
Total Posts:  55
Joined:  2008-04-06
 

Wow-- I wanted to stop bumping these threads but what’s going on?  I’m still in the same shoe!

 
Magento Community Magento Community
Magento Community
Magento Community
 
The Sunday Paper
Sr. Member
 
Total Posts:  202
Joined:  2008-08-06
 

I’m seeing the same issue. Has no one out there solved it before?

 
Magento Community Magento Community
Magento Community
Magento Community
 
l0st
Member
 
Total Posts:  55
Joined:  2008-04-06
 

Yes-- I’m still in the same shoes as well. No one wants to help us.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wsj3
Guru
 
Avatar
Total Posts:  521
Joined:  2008-07-13
Portland, OR
 

Did anyone ever get this fixed?

 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

OP error sounds like it was caused because there are 2 different domains being thrown around. If you have your certificate generated for “domain.com” then you can only use any secure urls with domain.com. If you decide to stick a www in front then you’ll get an error, as they are treated as 2 separate sites.

callback url should be https://domain.com/googlecheckout/api - you might need to stick index.php in there if you don’t use url rewrites

 
Magento Community Magento Community
Magento Community
Magento Community
 
satish
Enthusiast
 
Total Posts:  812
Joined:  2008-03-24
34,mantri Sadan,Shivaji Nagar,Nagpur,MS,India 4400
 

While you will use “Google Checkout” method on production mode server. So your site must have “ssl” URL.

You should check the “CallbackURL” in your “Google Checkout merchant profile”.

To set the “callbackurl” see the following:

For this Login to your Google Merchant account...

For 
Set API callback URL go to the "Integration" page under the "Settings" tab
Your API callback URL Will be
:

NoteThat the production Checkout server requires an SSL callback site.

https:// <url-site-url >/index.php/googlecheckout/api

And The Sandbox server accepts non SSL callback URLs
http://<url-site-url>/index.php/googlecheckout/api
It will help you!

Satish

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top