Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 5
Error: Please check for sufficient write file permissions
 
playforward
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-05-27
Sandpoint, Idaho
 

I’m trying to use the Magento Connect Downloader and keep getting the “Error: Please check for sufficient write file permissions” error.
I’ve even chmod 777 on all files and folders within my magento installation and it’s still not working.
Is there any other way to download these extensions? I was looking to download the Magento Modern Theme.

Any help would be greatly appreciated.
Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

If you have SSH, run the following commands:

find . -type d -exec chmod 777 {} \;
find . -type f -exec chmod 644 {} \;

That will reset all files to 644 and all directories to 777. After that you shouldn’t have any permissions errors. If you don’t have SSH and you’re hosted by someone, have them run this for you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
playforward
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-05-27
Sandpoint, Idaho
 

I contacted the host about running that.

Though, shouldn’t it still work with every file and folder set to 777?

what else could be my problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
playforward - 19 June 2008 08:40 PM

I contacted the host about running that.

Though, shouldn’t it still work with every file and folder set to 777?

what else could be my problem?

Yes, but that error is telling you that this is not the case. Set the permissions and that error will go away.

 
Magento Community Magento Community
Magento Community
Magento Community
 
playforward
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-05-27
Sandpoint, Idaho
 

ok, after my host ran that it allowed me to enter the KEY.

This is the error I get:

Failed to download magento-core/Interface_Frontend_Default_Modern within preferred state “stable”, latest release is version 1.0.19871, stability “beta”, use “channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern-1.0.19871” to install
Cannot initialize ‘channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern’, invalid or missing package file
Install Errors
Package “channel://connect.magentocommerce.com/core/Interface_Frontend_Default_Modern” is not valid
PEAR ERROR: install failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

Is there anything listed when you’re in MagentoConnect? You should see a bunch of extensions listed (the core ones for Magento). If not, enter the following into the extension key field and click the Install button:

magento-core/Mage_All_Latest

Don’t forget to put a checkmark next to Clear all sessions after successfull install or upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
playforward
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-05-27
Sandpoint, Idaho
 

Nothing was listed so I did what you mentioned and that downloaded a bit.

I tried to run the Modern theme again and it gave me another error (the same as before)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
playforward - 20 June 2008 09:40 PM

Nothing was listed so I did what you mentioned and that downloaded a bit.

I tried to run the Modern theme again and it gave me another error (the same as before)

Go to the Settings tab in MagentoConnect and try changing your preferred state to either Beta or Stable. Whatever it’s on, switch it to the other.

Also, after you ran that command, do you see a bunch of core extensions in there?

 
Magento Community Magento Community
Magento Community
Magento Community
 
playforward
Jr. Member
 
Avatar
Total Posts:  8
Joined:  2008-05-27
Sandpoint, Idaho
 

ok, that worked. I didn’t realize that the Modern Theme was Beta.

Thanks for the help.
also, yes, the extensions are now shown.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Unirgy
Guru
 
Avatar
Total Posts:  478
Joined:  2007-09-07
 

Hey, you can also add “-beta” for the extension key, without changing the global settings smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 
playforward - 21 June 2008 03:07 PM

also, yes, the extensions are now shown.

Great, well now you can update Magento using the downloader now and stay up to date smile

Oh, and great tip, Saharian, didn’t realize you could do that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ontwerp
Jr. Member
 
Total Posts:  5
Joined:  2008-07-02
 

Congratulations! Your server meets the requirements for Magento.

* You have PHP 5.2.0 (or greater)
* Safe Mode is off
* You have MySQL 4.1.20 (or greater)
* You have the curl extension
* You have the dom extension
* You have the gd extension
* You have the hash extension
* You have the iconv extension
* You have the mcrypt extension
* You have the pcre extension
* You have the pdo extension
* You have the pdo_mysql extension
* You have the simplexml extension

But i cannot install extensions with the magento downlaoder :

- can set switch to beta setting
- nor even a stable download will give me a : INVALID POST DATA

Anyone ???

System works via php5-cgi admin little bit slow but shop is allright

Anyone ???

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

I am having this same error, my SSH Terminal in Plesk is grayed out currently. I am wondering the correct way to enable it?

Under “Shell access to server with FTP user’s credentials”, what do I select?

/bin/bash
/bin/sh
/sbin/nologin
/bin/tcsh
/bin/csh
/bin/bash (chrooted)
/bin/rbash

I am unsure which one does anyone know?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

I chose bin/bash and used the permission change commands. I still get ‘nvalid file permissions, could not save configuration.’ What could be going on here?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

When I try putting in Mage_All_Latest in the extension I get the following error:

parsePackageName(): invalid package name “Mage_All_Latest “ in “connect.magentocommerce.com/core/Mage_All_Latest “
invalid package name/package file “connect.magentocommerce.com/core/Mage_All_Latest “
Cannot initialize ‘connect.magentocommerce.com/core/Mage_All_Latest ‘, invalid or missing package file
Install Errors
Package “connect.magentocommerce.com/core/Mage_All_Latest “ is not valid
PEAR ERROR: install failed

Anyone know what the problem could be?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Thejosh13
Sr. Member
 
Total Posts:  252
Joined:  2008-06-23
 

Can anybody please help?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 5