Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 7 of 7
Poll
Do you have USPS shippin methods set-up and working?
Yes, works perfect... 50
Yes, but it took a long time... 37
No, I still can’t get it to work right... 295
No, never really tried... 46
Total Votes: 428
You must be a logged-in member to vote
USPS - Everyone’s Issue
 
bdllc
Jr. Member
 
Total Posts:  5
Joined:  2013-06-02
 

@stewdog35, I did as you suggested and enabled ALL shipping methods with USPS in the shipping methods section of configuration.  Doing so caused a single USPS method to be displayed on the front end, it was a flat-rate box.  I looked again at my configuration and found my container setting was set to flat-rate box.  Changed that to Variable and alacazam, all applicable USPS methods and rates displayed on th front end.  Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Xedios
Member
 
Avatar
Total Posts:  42
Joined:  2009-08-19
Lancaster, PA
 

Getting USPS to display properly can be finicky. Making sure config settings are set properly, clearing cache etc. The USPS has gotten better about notifying developers before they make changes on the server side.

 
Magento Community Magento Community
Magento Community
Magento Community
 
designershopp
Jr. Member
 
Total Posts:  1
Joined:  2013-09-18
 

Hello,
I’m having an issue with USA domestic shipping rates. USPS only displays media and library shipping option. When i remove these options from the list i get an error message. But it works fine for international rates, displays all available options.

Does anyone know how to fix this issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
mco3
Jr. Member
 
Total Posts:  1
Joined:  2013-11-18
 

Hi designershopp,

I’m new to Magento here and I\\\’m experiencing the exact same issue that you describe: only media and library shipping options are displaying. Did you ever figure this out?

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
archonprime
Jr. Member
 
Total Posts:  6
Joined:  2013-10-26
 

Has anyone solved this?  I am having the same issue of only getting Media and Library rates displayed (whatever those are).

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brad Bredehoft
Jr. Member
 
Total Posts:  1
Joined:  2010-08-17
 

I am having the same problem. I called USPS and they verified that my account is authorized for additional shipping methods but they still are not showing up.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 7 of 7