Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

“Home” links adding extra trailing slash, breaking. 
 
mbilokonsky
Jr. Member
 
Total Posts:  2
Joined:  2008-06-11
 

I’ve seen this problem mentioned in various places, but I’ve never seen it resolved.

Right now, every time Magento creates a link to the home page it sends users to “www.myurl.com/magento/index.php/” with that trailing slash.  This leads to an error - “No input file specified.”

If I remove the slash from the URL it works fine.

Does anyone know what’s up with that?  I’ve tried various .htaccess modifications as prescribed in various forum posts, but none of them work.

Right now it seems like my best option is simply to manually change every occurrence of that link, but that solution seems sloppy at best.

So, any thoughts?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Hi,

What is your base URL in your .htaccess file (under RewriteBase)? Seems to me that this is the cause of your problems.

Lisa

 
Magento Community Magento Community
Magento Community
Magento Community
 
herbou1
Jr. Member
 
Total Posts:  1
Joined:  2008-12-15
 

Had the same problem.

Solved it by going to admin section -> system -> configuration -> web -> Url options -> Add Store Code to Urls -> Yes

Hope this will help you to.

regards,

Herbou1

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top