Magento Forum

   
KONTENT und Magento
 
vinoCrew84
Jr. Member
 
Total Posts:  2
Joined:  2008-06-16
 

Hallo!

Habe einen KONTENT-Server und bekomme beim aufruf der Installation immer folgenden Fehler:

Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.
‘; exit; } $mageFilename = ‘app/Mage.php’; if (!file_exists($mageFilename)) { if (is_dir(’downloader’)) { header("Location: downloader"); } else { echo “app/Mage.php not found”; } exit; } require_once $mageFilename; umask(0); Mage::run();

Erstens sieht es ganz nach einem Syntax-Fehler im Sourcecode aus wegen dem Quellcode und zweitens sagt mir die magento_check.php, dass mein Server geeignet ist:

Congratulations! Your server meets the requirements for Magento.

* You have PHP 5.2.0 (or greater)
* Safe Mode is off
* You have MySQL 4.1.20 (or greater)
* You have the curl extension
* You have the dom extension
* You have the gd extension
* You have the hash extension
* You have the iconv extension
* You have the mcrypt extension
* You have the pcre extension
* You have the pdo extension
* You have the pdo_mysql extension
* You have the simplexml extension

Ich verwende folgende .htaccess

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

DirectoryIndex index.php

RewriteEngine on
RewriteBase /shop/
RewriteCond %{REQUEST_URI} !^/media/
RewriteCond %{REQUEST_URI} !^/skin/
RewriteCond %{REQUEST_URI} !^/js/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
RewriteRule .* index.php

Wenn ich die .htaccess lösche, dann bekomme ich statt der obigen Meldung nur

No input file specified

Kommentiere ich in der .htaccess die erste Zeile aus, dann bietet er mir die php-cgi zum download an, die zweite Zeile scheint gar keinen EInfluss zu haben.

Wäre toll, wenn mir jmd. helfen kann. Danke schonmal!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Can you make sure whether your host is fully compatible with Magento Commerce?

Können Sie sich sicher sind, ob Ihr Gastgeber ist voll kompatibel mit Magento Commerce?

 
Magento Community Magento Community
Magento Community
Magento Community
 
jan212
Guru
 
Avatar
Total Posts:  407
Joined:  2008-01-03
 

Deine Glaskugel heißt PHP Version. Lege mal eine info.php mit folgendem Inhalt auf deinen Webspace und teile uns anschließend den Link oder deine PHP Version mit.

<?php 
phpinfo
();
?>

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top