Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
How to install a new theme
 
rabol
Jr. Member
 
Total Posts:  4
Joined:  2008-05-05
Gatten,Farsø
 

Hi

I have downloaded the ‘Modern theme’ through Magento connect’ but when I try to use it, the front end is just displaying an empty page.

Is there a ‘Install and configure a theme for dummies’?

(Yes I have cleared the cache)

Br
Steen

 
Magento Community Magento Community
Magento Community
Magento Community
 
norbolig
Guru
 
Total Posts:  328
Joined:  2008-03-15
 

Hi rabol,

your startup page is named Home page, and you will find this under CMS in the admin section.

Try to add this code in the Content field:

{{block type="core/template" template="sample/home.phtml"}}

Move on to the Custom Design, and add this:

Custom Theme:  modern
Layout:  1 column
Layout Update XML: {{block type="core/template" template="sample/home.phtml"}}

This should give you the default template layout on your front page.

(If you prefer to begin with the default layout, you can change the code to the one that comes with the default layout.)

 
Magento Community Magento Community
Magento Community
Magento Community
 
Crucial
Enthusiast
 
Avatar
Total Posts:  770
Joined:  2007-11-07
Phoenix, AZ
 

After you install the theme, go to System -> Configuration -> Design.

For the Themes section, set everything to modern, since that’s the name of the theme.

The theme will now be applied.

If you’re running the default install, you can make the front page look how the demo store on here does. For that you’ll need to update the CMS blocks, so go to CMS -> Manage Pages. Click on the Home Page.

You’ll be in the General Information section. Under Content, put the following:

{{block type="core/template" template="sample/home.phtml"}}

You can either comment out what’s already there, or just remove it completely.

Then you need to go to Custom Design and set the Layout to 1 column.

That’s it!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jpchen
Jr. Member
 
Total Posts:  5
Joined:  2008-09-30
 

I added blue theme from MagentoConnect, and it is listed there. I followed your instruction to add the home page, but I got hundreds of errors like:

{mydomain}/app/design/frontend/default/default/template/sample/home.phtml): failed to open stream: No such file or directory in {mydomain}/app/code/core/Mage/Core/Block/Template.php on line 144
...

I do not have the sample folder under template. I did a full installation from scratch with the full version 1.1.6 zip file. It’s supposed to contain sample data, but actually not. Do I have to install sample data seperately? How to fine it and how to do? Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
newtothis
Jr. Member
 
Total Posts:  28
Joined:  2008-08-07
 

Hi jpchen

You will need to install the sample data first

you should find more info here: http://www.magentocommerce.com/knowledge-base

 
Magento Community Magento Community
Magento Community
Magento Community
 
Robert H
Member
 
Avatar
Total Posts:  38
Joined:  2008-11-16
 

I installed the theme, and added the recommended block for the home page. Now nothing on website works! I no longer have categories, products are unsearchable and all links on the main page are blank pages! (example: http://shop.enveeapparel.net/index.php/customer/account/login/)

Secondly, where can I find the referenced block “sample/home.phtml” on my server to edit the home page content?

http://shop.enveeapparel.net/index.php/

UPDATE*******

I can get my products and pages to show up, although the catagories are still missing and I cannot find where to edit the images for the main page.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Vossie75
Sr. Member
 
Total Posts:  133
Joined:  2008-12-19
 

After you install the theme, go to System -> Configuration -> Design.

For the Themes section, set everything to modern, since that’s the name of the theme.

The theme will now be applied.

for me this is not working.
I have uploaded the design/theme/layout (whatevver you call this) to the following directory’s:

app/design/frontend/default/shopname
and
skin/frontend/default/shopname

for themes section in system -> design i have set all fields to shopname but in frontend still the default layout is used.

catch is reloaded and switched of but makes no difference.

What are i’m doing wrong?

 
Magento Community Magento Community
Magento Community
Magento Community
 
geemint
Jr. Member
 
Total Posts:  5
Joined:  2009-04-12
 

I like your site man. Real nice. Are you using modern theme? Real good job man. Good luck with your brand! I will tell people about it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
erow80
Jr. Member
 
Total Posts:  18
Joined:  2009-08-06
 

After you install the theme, go to System -> Configuration -> Design.

For the Themes section, set everything to modern, since that’s the name of the theme.

The theme will now be applied.

I’ve done this and and double-checked multiple times and am seeing no results. I’ve also cleared the cache and anything else I can think of. Anyone know why my changes aren’t taking place? Oddly enough, I’m trying to install the same theme on another server and it works…

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jazkat
Sr. Member
 
Total Posts:  154
Joined:  2009-07-09
 

I had the same problem as Vossie75.

My solution was to log-out of frontend and backend system! And then it worked.

PS: You can also find good explanation on setting up themes:
http://activecodeline.com/setting-up-development-environment-for-magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
jazkat
Sr. Member
 
Total Posts:  154
Joined:  2009-07-09
 

After further testing I noticed, that
if I’m browsing the products pages, then it’s taking theme “default\default”
on every other page I have “shopname\default” theme.

My setting in admin system for Default config (all webstores) is Current package theme: shopname.

My folders:
app/design/frontend/shopname/default
skin/frontend/shopname/default

Strange, strange…

EDITED 4.feb.2010:
Ok, new discoveries.. I remembered that I as a very smart person (not) was when creating new products also changed default design there and forgot to save it back to empty. So this was the reason when browsing products Magento was retrieving default templating files.  grin All I can say is stupid stupid stupid me.

Hope it helps someone grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
ktripp
Jr. Member
 
Avatar
Total Posts:  29
Joined:  2007-12-21
Missouri
 

Well i am having somewhat of a similar problem.  Everything was working great until I went in and changed the page title. I left the url indicator alone. And now i don’t have any images on the front page. I have no idea what is happening. Can anyone help? Thanks.

Image Attachments
Untitled-1.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Lacaster
Jr. Member
 
Total Posts:  1
Joined:  2010-08-23
 

Vossie75, did you give all permissions for the folders and files?

I was with the same problem and I solved that by giving permissions to folders and files.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sadleir
Jr. Member
 
Total Posts:  1
Joined:  2010-11-08
 

Please help me about this, i want to install new theme in my phone, but i can’t do that, so please help me how i do this.
Illumibrite

 
Magento Community Magento Community
Magento Community
Magento Community
 
prestigemv
Jr. Member
 
Total Posts:  10
Joined:  2010-02-27
 

dont frustrate yourselves guys…

replace:

{{block type=\"core/template\" template=\"sample/home.phtml\"}}

with this:

<div class=\"std\">
<
div style=\"float: left; width: 653px;\"><img src=\"http://demo3.magentocommerce.com/skin/frontend/default/modern/images/media/home_co_main.jpg\" alt=\"\" /></div>
<
div style=\"float: right; width: 280px;\">
<
div style=\"margin: 0 0 10px;\"><img src=\"http://demo3.magentocommerce.com/skin/frontend/default/modern/images/media/home_co_tr.gif\" alt=\"\" /></div>
<
div><img src=\"http://demo3.magentocommerce.com/skin/frontend/default/modern/images/media/home_co_br.gif\" alt=\"\" /></div>
</
div>
<
div style=\"margin: 10px 0 0;\"><img src=\"http://demo3.magentocommerce.com/skin/frontend/default/modern/images/media/home_co_bottom.gif\" alt=\"\" /></div>
</
div>

smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
cupandacu
Jr. Member
 
Total Posts:  30
Joined:  2010-12-23
 

Hi Guys,

I am close but no cigar!
Please see the attached image to see where I am up to with my modern theme. The 2 banners should be to the right of the main banner but you can see they are out of place.

I have taken a screen shot of what I have what the ‘Design’ section of my ‘Home Page’ CMS looks like also..
As you can see I have set the the page to 1 column also..

I am sure the solution must be simple, but I’m an idiot grin

Anyone?

Cheers,

Image Attachments
modern theme issue.JPGmodern theme issue2.JPG
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2