Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Custom theme - how to properly set it up and prevent it from being overwritten? 
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Hello,

I would like to modify the current default theme/skin. From what I understand, I need to copy the following directories:

1.
app/design/frontend/default/default

now I have

app/design/frontend/default/MYSKIN

2.skin/frontend/default/default

now I have

skin/frontend/default/MYSKIN

What do I need to do in my back-end? Is this the proper way to do it so it is not overwritten when updating Magento through Magento connect?

Many thanks!
Lisa

 
Magento Community Magento Community
Magento Community
Magento Community
 
crius
Guru
 
Avatar
Total Posts:  623
Joined:  2007-10-16
Denmark
 

You are exactly right. You just need to go to System -> Configuration -> Design, and in the field Default under Themes, change default to MYSKIN.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Hi Anders,

Many thanks for your reply.

I have tried as you suggested, and turned the template hints on to see where it’s pulling all the files from. However, it’s still taking everything from

frontend/default/default/

instead from

frontend/default/MYSKIN/

Hmm...Am I doing something wrong? Cache is disabled btw.

Lisa

 
Magento Community Magento Community
Magento Community
Magento Community
 
crius
Guru
 
Avatar
Total Posts:  623
Joined:  2007-10-16
Denmark
 

Hmm, it should be working. Maybe you will find something in the designer’s guide.

 
Magento Community Magento Community
Magento Community
Magento Community
 
lisali
Enthusiast
 
Avatar
Total Posts:  889
Joined:  2008-04-28
London, UK
 

Thanks Anders, it does work - my error! I had copied the wrong files.

All is working now.

Many thanks for your help!
Lisa

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top