Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Email to admin, Not Working! 
 
solomfb
Jr. Member
 
Avatar
Total Posts:  17
Joined:  2008-06-04
California
 

I’ve seen this posted elsewhere but it seems as it is not fixed so maybe this will get some more deserve attention?

I’m getting no emails sent to the admin from new customer sign ups,… or from purchases? I have a kind of makeshift invoice coming to me from orders by having a copy of the invoice sent to my (from: system > configuration > sales emails > “Send Order Email Copy To"). It just sends an exact copy of the invoice that goes to the customer, this at least lets me know I have an order to process. It just doesn’t seem to be the right way?

I would really like to have this resolved, I’ve spent more than half the day just trying different methods of getting this to work, it’s annoying because it seems like one of the easiest things to do. I would really like to be notified of new customer sign ups as well. I still could not find a way to get this working.

Another thing I can’t seem to get working is the “Need to Confirm,” under: system > configuration > customer configuration. I would like for customers to confirm their emails so I don’t have a mess of emails that really go nowhere. Anyone have this working properly? If so, how did you get this working? I’m brand new at this kind of stuff (backend, php stuff, I know html and CSS only for the most part), so I will need more details than a couple words, if you would be so kind.
{Edit} I just read, that the “Need to Confirm” is, if you (the admin) signs up a customer, an email is sent to the new customer to confirm the email address? Can someone let me know if this is the case? If it is, I think there should be an email confirmation for customers who sign up on their own as well.

So far that’s all the questions I have, I’ve been able to find most things that have come up other than that, I just can’t seem to find anything on these issues.

Thanks a lot.
Sol

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexNoosa
Jr. Member
 
Avatar
Total Posts:  10
Joined:  2008-09-16
Noosa, Australia
 

hey mate

i couldn’t get the admin emails to work either

I’ve been playing around with the code at

app/code/core/mage/sales/model/order.php

i just added my own mail function

still testing it, i will post the code when it is ready

 
Magento Community Magento Community
Magento Community
Magento Community
 
solomfb
Jr. Member
 
Avatar
Total Posts:  17
Joined:  2008-06-04
California
 
alexNoosa - 22 September 2008 04:50 PM

hey mate

i couldn’t get the admin emails to work either

I’ve been playing around with the code at

app/code/core/mage/sales/model/order.php

i just added my own mail function

still testing it, i will post the code when it is ready

Basically, what I got it to do is send me a copy of what the customer ordered. So that’s how I deal with knowing that an order was placed. I’m not sure if that’s what is really supposed to happen, but it works.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top