Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Invalid category problem
 
vladeta
Jr. Member
 
Total Posts:  19
Joined:  2008-11-26
 

Hi,

There is strange (and serious) error appearing on front page of http://tokyozakka.com. It appears on front page and showing of front page items is sorted by making hidden category, adding all products to that category and displaying

{{block type="catalog/product_list" category_id="34" template="catalog/product/list.phtml"}}
in home page.
I figure that it has something to do with categories, but cant find what.
Is there any way of finding what the problem is? Can anyone help please?

Regards,
Vladeta

 
Magento Community Magento Community
Magento Community
Magento Community
 
vladeta
Jr. Member
 
Total Posts:  19
Joined:  2008-11-26
 

Anyone has any idea?
I would use any help, cause I really cant solve this…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Al Capone
Jr. Member
 
Total Posts:  4
Joined:  2009-02-09
 

Can anyone tell me how I can fix this, I have the exact same problem… I know the category exists but I get this error…

 
Magento Community Magento Community
Magento Community
Magento Community
 
vladeta
Jr. Member
 
Total Posts:  19
Joined:  2008-11-26
 

I still don’t know how to fix this.
But I have found solution to my problem in restoring backup mysql from my hosting provider. Maybe you can try to do the same…

Vladeta

 
Magento Community Magento Community
Magento Community
Magento Community
 
Al Capone
Jr. Member
 
Total Posts:  4
Joined:  2009-02-09
 

quoted from my post in another thread…

Flaxion - 08 December 2008 04:55 PM
Okay I actually think I got it now rasberry

um.. I just changed the root category under business administration.

to elaborate on his solution, you need to go to system -> manage stores

click on your store and change the root category from whatever it is to the root category for your site… basically, it was set to another category or no category at all because you deleted or are not using the default root… im amazed no one else was able to just tell us this, it wasnt rocket science, i’m new here but the support forum seems pretty nonsupporting… but hey, hope my post helps you guys smile

that should fix your problem man, but it sucks that sumthin so simple wasn’t addressed by someone early… i was a bit faded last night so i had to take a second look this morning but it works now and shud work for you, goodluck wink

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top